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1. Introduction

This version of Cytoscape builds upon
the new 3.x architecture, developer API and set of user controls established. If you’re familiar with former versions of Cytoscape,
this version will feel completely familiar and you’ll be all set to go.
In future releases, we will continue to tweak and improve both the
software and the documentation. This manual will be updated to reflect
all the latest changes.

If you would prefer to learn by doing, consider starting with the Basic Expression Analysis Tutorial [https://cytoscape.org/cytoscape-tutorials/protocols/basic-data-visualization/#/].

This manual describes the installation and use of Cytoscape. For a more
thorough understanding of Cytoscape and its ecosystem, we highly
recommend reading the Welcome Letter accessible on the
http://cytoscape.org website.





          

      

      

    

  

    
      
          
            
   


2. Launching Cytoscape

Cytoscape is a Java application verified to run on the Linux, Windows,
and Mac OS X platforms. Although not officially supported, other UNIX
platforms such as Solaris or FreeBSD may run Cytoscape if Java version 8
is available for the platform.

 


2.1. System Requirements

The system requirements for Cytoscape depend on the size of the networks
you want to load, view and manipulate.

Note that as of Cytoscape v3.2, networks are loaded faster and in less
memory than with previous versions. While this is good news, networks
created on v3.2 on a given memory configuration (e.g., 1GB) may not be
loadable by prior Cytoscape versions on the same memory configuration.


Required Resources
 	                           	Small Network Visualization 	Large Network Analysis/Visualization              

 	Processor     	1GHz               	As fast as possible, with multiple cores 

 	Memory     	512MB           	2GB+                                  

 	Graphics Card 	Integrated video   	High-end graphics card                   

 	Monitor    	XGA (1024X768)  	Wide or Dual Monitor                  



Specific system requirements, limitations, and configuration options
apply to each platform, as described in the Release Notes available
on the http://cytoscape.org website.
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3. Command Line Arguments

Cytoscape recognizes a number of optional command line arguments,
including run-time specification of network files, node and edge data
files, and session files. This is the output generated when Cytoscape is
executed with the “-h” or “–help” flag:

usage: cytoscape.{sh|bat} [OPTIONS]
 -h,--help             Print this message.
 -v,--version          Print the version number.
 -s,--session <file>   Load a cytoscape session (.cys) file.
 -N,--network <file>   Load a network file (any format).
 -P,--props <file>     Load cytoscape properties file (Java properties
                       format) or individual property: -P name=value.
 -V,--vizmap <file>    Load vizmap properties file (Cytoscape VizMap
                       format).
 -S,--script <file>    Execute commands from script file.
 -R,--rest <port>      Start a rest service.





Any file specified for an option may be specified as either a path or as
a URL. For example you can specify a network as a file (assuming that
myNet.sif exists in the current working directory):
cytoscape.sh -N myNet.sif.

Note: if there are spaces in the file path, be sure to put quotes around
it:
cytoscape.bat -N "C:\Program Files\Cytoscape\sampleData\galFiltered.sif".

Or you can specify a network as a URL:
cytoscape.sh -N http://example.com/myNet.sif.


Command Line Arguments
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4. Quick Tour of Cytoscape

This chapter describes the basic layout and mechanics of using Cytoscape. If you would prefer to learn by doing, consider starting with the Basic Expression Analysis Tutorial [https://cytoscape.org/cytoscape-tutorials/protocols/basic-data-visualization/#/].

 


4.1. Starter Panel

When you start Cytoscape, you can access basic functions from the
Starter Panel:

[image: Welcome_37.png]

The Starter Panel is designed to give you quick access to a set of sample session files,
as well as tutorials and Cytoscape news. The sample session files include a broad range of networks
to give a sense of the diversity of interaction types, visualization styles and biological applications (see
Network Table properties for more information about each sample session network).
The Starter Panel will also present your own most recent sessions for quick access.

When you load a session file, the Starter Panel will disappear. You can display it at any
time by choosing View → Show Starter Panel.

For
information on user privacy, see the Cytoscape Privacy
Policy.

 




4.2. Basic Features

When a network is loaded, Cytoscape will look similar to the image
below:

[image: NetworkLoaded37.png]

Most functionalities are self-explanatory, but we’ll go through a
concise explanation for clarity. The main window here has several
components:


	The Menu Bar at the top (see below for more information about
each menu).


	The Tool Bar, which contains icons for commonly used functions.
These functions are also available via the menus. Hover the mouse
pointer over an icon and wait momentarily for a description to
appear as a tooltip. Right-clicking on the tool bar allows the
contents to be customized.


	The Network Panel (Network tab of the Control Panel, top left).
At the top of the Network Panel is a Search bar, with direct access
to multiple external resources. The network panel also
contains an optional network overview pane (shown at the
bottom left).


	The main Network View Window, which displays the network.


	The Table Panel (bottom right panel), which displays columns of
selected nodes and edges and enables you to modify the values of
column data.




The Network Panel and Table Panel are dockable tabbed Panels. You can
undock any of these panels by clicking on the Float Window control
[image: FloatWindow-v31.png]
in the upper-right corner of the CytoPanel. This is useful when you want
assign the network panel as much screen space as possible. To dock the
window again, click the Dock Window icon
[image: DockWindow.png].
Clicking the Hide Panel icon
[image: HideWindow.png]
will hide the panel; this can be shown again by choosing View → Show
and selecting the relevant panel.

If you click this control, for example on the Table Panel, you will now
have two Cytoscape windows, the main window, and a new window labeled
Table Panel, similar to the one shown below. A popup will be displayed
when you put the mouse pointer on a cell.

[image: TablePanel37.png]

Note that Table Panel now has a Dock Window control. If you click this
control, the window will dock onto the main window. For more information
on the panels in Cytoscape, see the
Panels
section.

 


Network Editing

Cytoscape also has an edit functionality that enables you to build and
modify networks interactively within the network canvas. To edit a
network, just right-click on the open space of network window, select
the menu item Add → Node, a new node will be added to the canvas. To
add an edge, right click on a node, choose the menu item Edit → Add
Edge. Then select the target node, a new edge will be added between
the two nodes. In a similar way annotation objects can be added;
pictures, shapes or textboxes; much like in MS PowerPoint or similar
software. Detailed information on network editing can be found in the
Editing Networks
section.

[image: AddNodeMenu37.png]

 






4.3. The Menus

 


File

The File menu contains most basic file functionality: File → Open
for opening a Cytoscape session file; File → New Network for creating a new
network, either blank for editing, or from an existing network; File →
Save for saving a session file; File → Import for importing data
such as networks and tables; and File → Export for exporting data.
File → Export Network to Image lets you export the
network in either JPEG, PDF, PNG, PostScript or SVG format.
File → Export Network to Web Page lets you export the entire session or
a single network as a Web page using Cytoscape.js.

File → Recent Session will list recently opened session files for
quick access. File → Print… allows printing.

[image: FileMenu37.png]

 




Edit

The Edit menu contains Cut, Copy and Paste functions, as
well as Undo and Redo functions which undo and redo edits made
in the Table Panel, the Network Editor and to layout.

There are also options for creating and destroying views (graphical
representations of a network) and networks (the raw network data - not
yet visualized), as well as an option for deleting selected nodes and
edges from the current network. All deleted nodes and edges can be
restored to the network via Edit → Undo.

There are also other editing options; Remove Duplicated Edges will
delete edges that are duplicates (having the same source and target nodes), keeping one edge, Remove
Self-Loops removes edges that have the same source and target node,
and Delete Selected Nodes and Edges… deletes a selected subset of
the network. Rename Network… allows you to rename the currently
selected network.

Editing preferences for properties and apps is found under Edit →
Preferences → Properties…. More details on how to edit preferences
can be found
here.

[image: EditMenu37.png]

 




View

The View menu allows you to display or hide the Control Panel,
Table Panel, Result Panel, Tool Panel and the Automation Panel. It also
provides the control of other view-related functionality.

[image: ViewMenu37.png]

 




Select

The Select menu contains different options for selecting nodes and
edges.

[image: SelectMenu37.png]

 




Layout

The Layout menu has an array of features for visually organizing the
network. The features in the top portion of the network (Bundle
Edges, Clear Edge Bends, Node Layout Tools) are tools for
manipulating the network visualization. The
bottom section of the menu lists a variety of layout algorithms which
automatically lay a network out.

[image: LayoutMenu37.png]

 




Apps

The Apps menu gives you access to the App Manager (Apps → App
Manager) for managing (install/update/delete) your apps and may have
options added by apps that have been installed. Depending on which apps
are loaded, the apps that you see may be different than what appear
here. The below picture shows a Cytoscape installation without installed
apps.

[image: AppsMenu.png]

Note: A list of available Cytoscape apps with descriptions is available online at: http://apps.cytoscape.org

In previous versions of Cytoscape, apps were called plugins and served a
similar function.

 




Tools

The Tools menu contains advanced features like Network Analyzer, Cytoscape Web Browser, Network Merge, Execute Command File…, Job Status Monitor, Run Script File… and Diffuse.

Cytoscape Web Browser allows for viewing any html page directly in Cytoscape. The web browser can be opened in a separate window or can be launched in the Results Panel.

[image: ToolsMenu37.png]

 




Help

The Help menu allows you to launch the online help viewer and browse
the table of contents for this manual (Contents).

[image: HelpMenu37.png]

The Citations option displays the main literature citation for
Cytoscape, as well as a list of literature citations for installed apps.
The list will be different depending on the set of apps you have
installed.

[image: Citations.png]

The Help menu also allows you to connect directly to Cytoscape Help
Desk and the Bug Report interface.

 






4.4. Network Management

Cytoscape allows multiple networks to be loaded at a time, either with
or without a view. A network stores all the nodes and edges that are
loaded by the user and a view displays them.

An example where a number of networks have been loaded is shown below:

[image: MultipleNetworkView37.png]

The network manager (in Control Panel) shows the networks that are
loaded. Clicking on a network here will make that view active in the
main window, if the view exists. Each network has a name and size
(number of nodes and edges), which are shown in the network manager. If
a network is loaded from a file, the network name is the name of the
file.

Some networks are very large (thousands of nodes and edges) and can take
a long time to display. For this reason, a network in Cytoscape may not
contain a “view”. Networks that have a view are in normal black font and
networks that don’t have a view are highlighted in red. You can create
or destroy a view for a network by right-clicking the network name in
the network manager or by choosing the appropriate option in the
Edit menu. You can also destroy previously loaded networks this way.

Certain operations in Cytoscape will create new networks. If a new
network is created from an old network, for example by selecting a set
of nodes in one network and copying these nodes to a new network (via
the File → New Network option), it will be shown immediately
follows the network that it was derived from.

Network views can also be detached (undocked) from the main Cytoscape window. When detached, a view window can be dragged to another monitor, resized, maximized and minimized by using the normal window controls for your operating system. Notice, however, that closing a view window does not destroy it, but simply reattaches it to the Cytoscape window.

 


Arrange Network Windows

When you have detached network view windows, you can arrange them by selecting one of these options under View → Arrange Detatched Views:

Grid

[image: MultipleNetworks_Grid.png]

Cascade

[image: MultipleNetworks_Cascade.png]

Vertical Stack

[image: MultipleNetworks_VerticalStack.png]

Side by Side

[image: MultipleNetworks_SidebySide.png]

 






4.5. The View Navigator

The View Navigator (or “bird’s eye view”)  is a control that shows an overview of the network.
It can be used to navigate around a large network view. The
blue rectangle indicates the portion of the network currently displayed
in the network view window, and it can be dragged with the mouse to view
other portions of the network. Zooming in will cause the rectangle to
appear smaller and vice versa. You can show or hide it by clicking the “Show/Hide Navigator” button [image: ViewNavigatorControl.png] or pressing the key “N”.

[image: network_overview_34.png]
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5. Creating Networks

There are 4 different ways of creating networks in Cytoscape:


	Importing pre-existing, fixed-format network files.


	Importing pre-existing, unformatted text or Excel files.


	Importing data from from public databases.


	Creating an empty network and manually adding nodes and edges.




 


5.1. Import Fixed-Format Network Files

Network files can be specified in any of the formats described in the
Supported Network
Formats
section. Networks are imported into Cytoscape via File →
Import. The network file can either be located directly
on the local computer, or found on a remote computer (in which case it
will be referenced with a URL).

 


Load Networks from Local Computer

In order to load a network from a local file you can select File →
Import → Network from File… or click on
[image: Cy3_icon_net_file_import.png]
on the tool bar. Choose the correct file in the file chooser dialog and
press Open. Some sample network files of different types have been
included in the sampleData folder in Cytoscape.

After you choose a network file, another dialog will pop up. Here, you
can choose either to create a new network collection for the new
network, or load the new network into an existing network collection.
When you choose the latter, make sure to choose the right mapping column
to map the new network to the existing network collection.

[image: ImportNetwork.png]

Alternatively, you can simply drag and drop a network file from the desktop into the Network list
(Control Panel), rather than selecting the file from the menu option.

Network files in SIF, GML, and XGMML formats may also be loaded directly
from the command line using the -N option.

 




Load Networks from a Remote Computer (URL import)

To load a network from a remote file, you can select File → Import →
Network from URL…. In the import network dialog, insert the appropriate
URL, either manually or using URL bookmarks. Bookmarked URLs can be
accessed by clicking on the arrow to the right of the text field (see
the Bookmark Manager in
Preferences
for more details on bookmarks). Also, you can drag and drop links from a
web browser to the URL text box. Once a URL has been specified, click on
the OK button to load the network.

[image: ImportNetworkFromURL.png]

Another issue for network import is the presence of firewalls, which can
affect which files are accessible to a computer. To work around this
problem, Cytoscape supports the use of proxy servers. To configure a
proxy server, go to Edit → Preferences → Proxy Settings…. This is
further described in the
Preferences
section.

 






5.2. Import Networks from Unformatted Table Files

Cytoscape supports the import of networks from delimited text files and
Excel workbooks using File → Import → Network from File…. An
interactive GUI allows users to specify parsing options for specified
files. The screen provides a preview that shows how the file will be
parsed given the current configuration. As the configuration changes,
the preview updates automatically. In addition to specifying how the
file will be parsed, the user must also choose the columns that
represent the source and target nodes as well as an optional edge
interaction type. For detailed instructions, see Basic Operations below.

[image: ImportNetworkDialog2.png]

 


Supported Files

The import function supports delimited text files
and Microsoft Excel Workbooks. For Excel Workbooks with multiple sheets,
one sheet can be selected for import at a time. The following is a
sample table file:


Sample Network in Table
 	source     	target     	interaction  	boolean data  	string data   	floating point data 

 	YJR022W    	YNR053C    	pp           	TRUE          	abcd12371     	1.2344543           

 	YER116C 	YDL013W 	pp       	TRUE      	abcd12372 	1.2344543       

 	YNL307C    	YAL038W    	pp           	FALSE         	abcd12373     	1.2344543           

 	YNL216W 	YCR012W 	pd       	TRUE      	abcd12374 	1.2344543       

 	YNL216W    	YGR254W    	pd           	TRUE          	abcd12375     	1.2344543           



The network table files should contain at least two columns for creating
network with edges. If the file has only one column, the created network
will not contain any edges. The interaction type is optional in this
format. Therefore, a minimal network table looks like the following:


Minimal Network Table
 	source     	target     

 	YJR022W    	YNR053C    

 	YER116C 	YDL013W 

 	YNL307C    	YAL038W    

 	YNL216W 	YCR012W 

 	YNL216W    	YGR254W    



One row in a network table file represents an edge and its edge data
columns. This means that a network file is considered a combination of
network data and edge column data. A table may contain columns that
aren’t meant to be edge data. In this case, you can choose not to import
those columns by clicking on the column header in the preview window.
This function is useful when importing a data table like the following
(1):

[image: sampleTableData1.png]

This data file is a tab-delimited text file and contains network data
(interactions), edge data, and node data. To import network and edge
data from this table, choose Unique ID A as source, Unique ID B as
target, and Interactor types as interaction type. Next, turn off columns
used for node data (Alternative ID A, species B, etc.). Other columns
can be imported as edge data.

The network import function cannot import node table columns - only edge
table columns. To import node table columns from this table, please see
the Node and Edge Column
Data
section of this manual.

Note (1): This data is taken from the A merged human interactome
datasets by Andrew Garrow, Yeyejide Adeleye and Guy Warner (Unilever,
Safety and Environmental Assurance Center, 12 October 2006). Actual data
files are available at http://wiki.cytoscape.org/Data_Sets/.
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6. Nested Networks

Cytoscape has the ability to associate a Nested Network with any
node. A nested network is any other network currently defined in
Cytoscape. This capability allows for creation of network hierarchies as
well as circular relationships. For example, various module-finding
plugins make use of nested networks in the overview network that they
generate. There each node representing a module contains a nested
network.

Note that Nested Networks are similar in concept to Groups, but with very different consequences. A Nested Network incorporates an independent network that does not share nodes or attributes with the current network – it can be edited only as a separate network collection or in a separate Cytoscape session. Its nodes cannot be connected to nodes in the current network and cannot be found or filtered using Cytoscape functions or apps. Conversely, nodes in a Group are part of the current network, can have edges to nodes outside of the group, and can be found or filtered using Cytoscape functions or apps.

Most often, Groups are more functional and easier to use.

 


6.1. Creating Nested Networks

There are currently two ways in which a user can create nested networks.


	By importing a Nested Network Format (NNF) file. (See: NNF
Network
Format).


	By manually constructing networks and assigning nested networks to
individual nodes through the right-click node context menu. (See
Nested Network Node Context
Menu).




 




6.2. Visualization of Nested Networks

Nodes containing nested networks that are zoomed in sufficiently display
an image for the nested network. If no current network view exists for
the nested network the image will be a default icon, otherwise it will
be a low-resolution rendering of the nested network’s current layout.

[image: NestedNetwork2.png]
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7. Supported Network File Formats

Cytoscape can read network/pathway files written in the following
formats:


	Simple interaction file (SIF or .sif format)


	Nested network format (NNF or .nnf format)


	Graph Markup Language (GML or .gml format)


	XGMML (extensible graph markup and modelling language).


	SBML


	BioPAX


	PSI-MI Level 1 and 2.5


	GraphML


	Delimited text


	Excel Workbook (.xls, .xlsx)


	Cytoscape.js
JSON [http://cytoscape.github.io/cytoscape.js/#notation/elements-json]


	Cytoscape CX [https://github.com/CyComponent/CyWiki/blob/master/docs/CX/CX.md]




The SIF format specifies nodes and interactions only, while other
formats store additional information about network layout and allow
network data exchange with a variety of other network programs and data
sources. Typically, SIF files are used to import interactions when
building a network for the first time, since they are easy to create in
a text editor or spreadsheet. Once the interactions have been loaded and
network layout has been performed, the network may be saved to GML or
XGMML format for interaction with other systems. All file types listed
(except Excel) are text files and you can edit and view them in a
regular text editor.

 


7.1. SIF Format

The simple interaction format is convenient for building a graph from a
list of interactions. It also makes it easy to combine different
interaction sets into a larger network, or add new interactions to an
existing data set. The main disadvantage is that this format does not
include any layout information, forcing Cytoscape to re-compute a new
layout of the network each time it is loaded.

Lines in the SIF file specify a source node, a relationship type (or
edge type), and one or more target nodes:

nodeA <relationship type> nodeB
nodeC <relationship type> nodeA
nodeD <relationship type> nodeE nodeF nodeB
nodeG
...
nodeY <relationship type> nodeZ





A more specific example is:

node1 typeA node2
node2 typeB node3 node4 node5
node0





The first line identifies two nodes, called node1 and node2, and a
single relationship between node1 and node2 of type typeA. The second
line specifies three new nodes, node3, node4, and node5; here “node2”
refers to the same node as in the first line. The second line also
specifies three relationships, all of type typeB and with node2 as the
source, with node3, node4, and node5 as the targets. This second form is
simply shorthand for specifying multiple relationships of the same type
with the same source node. The third line indicates how to specify a
node that has no relationships with other nodes. This form is not needed
for nodes that do have relationships, since the specification of the
relationship implicitly identifies the nodes as well.

Duplicate entries are ignored. Multiple edges between the same nodes
must have different edge types. For example, the following specifies two
edges between the same pair of nodes, one of type xx and one of type yy:

node1 xx node2
node1 xx node2
node1 yy node2





Edges connecting a node to itself (self-edges) are also allowed:

node1 xx node1





Every node and edge in Cytoscape has a name column. For a network
defined in SIF format, node names should be unique, as identically named
nodes will be treated as identical nodes. The name of each node will be
the name in this file by default (unless another string is mapped to
display on the node using styles). This is discussed in the section on
Styles.
The name of each edge will be formed from the name of the source and
target nodes plus the interaction type: for example,
sourceName (edgeType) targetName.

The tag  can be any string. Whole words or concatenated
words may be used to define types of relationships, e.g. geneFusion,
cogInference, pullsDown, activates, degrades, inactivates, inhibits,
phosphorylates, upRegulates, etc.
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8. Node and Edge Column Data

Interaction networks are useful as stand-alone models. However, they are
most powerful for answering scientific questions when integrated with
additional information. Cytoscape allows the user to add arbitrary node,
edge and network information to Cytoscape as node/edge/network data
columns. This could include, for example, annotation data on a gene or
confidence values in a protein-protein interaction. These column data
can then be visualized in a user-defined way by setting up a mapping
from columns to network properties (colors, shapes, and so on). The
section on
Styles
discusses this in greater detail.

 


8.1. Import Data Table Files

Cytoscape offers support for importing data from delimited text and MS
Excel data tables.

Sample Data Table 1


Sample Data
 	Object Key  	Alias        	SGD ID  

 	AAC3    	YBR085W|ANC3       	S000000289    
 
 	AAT2 	YLR027C|ASP5    	S000004017 

 	BIK1    	YCL029C|ARM5|PAC14 	S000000534    



The data table file should contain a primary key column and at least one
data column. The maximum number of data columns is unlimited. The
Alias column is an optional feature, as is using the first row of
data as column names. Alternatively, you can specify each column name
from the File → Import → Table from File… user interface.

 


Basic Operation

[image: ImportColumnsFromTable.png]


	Select File → Import → Table from File….


	Select a data file. The file can be either a text or
Excel (.xls/.xlsx) file.
Alternatively, you can simply drag and drop the file from the desktop into the Table Panel.


	In the Target Table Data section, choose where to import the
data to. You can choose an existing network collection, a specific
network only, or you can choose to import the data to an
Unassigned Table (described below).


	Depending on what you choose in the Where to import Table Data
drop-down, you will need to select a network collection or
specific network. You will also need to select Importing Type,
that is whether the data is node, edge or network table columns.


	If the table is not properly delimited in the preview panel, change
the delimiter in the Advanced Options panel. The default
delimiter is tab. This step is not necessary for Excel Workbooks.


	By default, the first column is designated as the primary key, as
designated by the key [image: Key.png]
icon. To set another column as the key instead, click the arrow at
next to the column title and select the key symbol. Make sure the
column designated as key matches the key in the network.


	Similarly, to change the data type of a column, for example from
integer to string, click the arrow next to the column title, and
select the correct data type.




[image: ChangeDataType.png]


	Click OK to import.





Unassigned Table

As of Cytoscape 3.1. it is possible to import data tables without
assigning them to existing networks, meaning the data doesn’t have to
correspond to any nodes/edges currently loaded. If a data table is
imported as unassigned and a network is later imported that maps to the
data in terms of nodes or edges, the data will link automatically. This
is useful when loading a large dataset (for example expression data),
defining a Style for visualizing the data on networks and later
loading individual networks to view the data, for example from an online
database. This feature allows the data to be automatically linked to any
network that is applicable, without having to load the data for each
network.
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9. Column Data Functions and Equations

 


9.1. Column Formulas

 


Introduction

Column data values may be formulas. A typical example is
=ABS($otherColumn + LOG(10.2)). Formulas are modeled after
Excel(tm) but only support references to other columns at the same node,
edge or network. Since Cytoscape column names may contain embedded
spaces, optional braces around the column name (required if the name is
not simply a letter followed by one or more letters or digits) is
allowed e.g. ${a name with spaces}. Backslashes, opening braces and
dollar signs in column names have to be escaped with a leading
backslash. For example the column name ex$am{p\le would have to be
written as ${ex\$am\{p\\le}. Finally, column names are case
sensitive.

String constants are written with double-quotes “. In order to embed
a double-quote or a backslash in a string they have to be escaped with a
leading backslash, therefore the string “\ must be written as
“\”\\”. Formula results must be compatible with the type of the
column that they have been assigned to. The rules are rather lax though,
for example anything can be interpreted as a string and all numeric
values will be accepted for a boolean (or logical) column data where
non-zero will be interpreted as true and zero as false. For
integer columns, floating point values will be converted using the rules
of the Excel(tm) INT function. Parentheses can be used for grouping
and to change evaluation order. The operator precedence rules follow
those of standard arithmetic.

 




Operators

Currently supported operators are the four basic arithmetic operators
and the ^ exponentiation operator. +, -, *, and
\ are left-associative and ^ is right-associative. The string
concatenation operator is &. Supported boolean or logical operators
are the comparison operators <, >, <=, >=,
=, and <> (not equal).

 




Supported Functions

Currently we support the following functions:


Cytoscape-specific functions


	Degree – the degree of a node.


	InDegree – the indegree of a node.


	OutDegree – the outdegree of a node.


	SourceID – the ID of the source node of an edge.


	TargetID – the ID of the target of an edge.







Numeric Functions


	Abs – Returns the absolute value of a number.


	ACos – Returns the arccosine of a number.


	ASin – Returns the arcsine of a number.


	ATan2 – Returns the arctangent of two numbers x and y.


	Average – Returns the average of a group of numbers.


	Cos – Returns the cosine of an angle given in radians.


	Cosh – Returns the hyperbolic sine of its argument.


	Count – Returns the number of numeric values in a list.


	Degrees – Returns its argument converted from radians to degrees.


	Exp – Returns e raised to a specified number.


	Ln – Returns the natural logarithm of a number.


	Log – Returns the logarithm of a number to a specified base.


	Max – Returns the maximum of a group of numbers.


	Median – Returns the median of a list of numbers.


	Min – Returns the minimum of a group of numbers.


	Mod – Calculates the modulus of a number.


	Pi – Returns an approximation of the value of p.


	Radians – Returns its argument converted from degrees to radians.


	Round – Rounds a number to a specified number of decimal places.


	Sin – Returns the sine of an angle given in radians.


	Sinh – Returns the hyperbolic sine of its argument.


	Sqrt – Calculates the square root of a number.


	Tan – returns the tangent of its argument in radians.


	Tanh – returns the hyperbolic tangent of its argument in radians.


	Trunc – Truncates a number.







String Functions


	Concatenate – Concatenates two or more pieces of text.


	Left – Returns a prefix of s string.


	Len – Returns the length of a string.


	Lower – Converts a string to lowercase.


	Mid – Selects a substring of some text.


	Right – Returns a suffix of a string.


	Substitute – Replaces some text with other text.


	Text – Format a number using the Java DecimalFormat
class’ conventions.


	Upper – Converts a string to uppercase.


	Value – Converts a string to a number.







Logical/Boolean Functions


	And – Returns the logical conjunction of any number of
boolean values.


	Not – Returns the logical negation of a boolean value.


	Or – Returns the logical disjunction of any number of
boolean values.







List Functions


	First – Returns the first entry in a list.


	Last – Returns the last entry in a list.


	Nth – Returns the n-th entry in a list.







Statistical Functions


	Largest – the kth largest value in a list.


	GeoMean – the geometric mean of a set of numbers.


	HarMean – the harmonic mean of a set of numbers.


	Mode – the mode of a set of numbers.


	NormDist – Returns the pdf or CDF of the normal distribution.


	Permut – Returns the number of permutations for a given number
of objects.


	StDev - sample standard deviation.


	Var – sample variance.







Miscellaneous Functions


	Combin - Returns the number of combinations for a given number
of objects.


	If – Returns one of two alternatives based on a boolean value.


	ListToString – Returns a string representation of a list.


	Now – Returns a string representation of the current date and time.


	Today – returns a string representation of the current date.




 






Pitfalls

The possibly biggest problem is the referencing of other columns that
have null values. This is not allowed and leads to errors. In order to
mitigate this problem we support the following optional syntax for
column references: ${columnName:defaultValue}. The interpretation
is that if columnName is null, then the default value will be used,
otherwise the value of the referenced value will be used instead. The
referenced column must still be a defined column and not an arbitrary
name! The other potential problem is when there are circular column
reference dependencies. Circular dependencies will be detected at
formula evaluation time and lead to a run-time error.

 




Useful Tips

When working with formulas it can be very helpful to open the
Developer’s Log Console. Formula evaluation errors will be logged there.

 






9.2. The Formula Builder

In order to ease the creation of formulas as well as to facilitate
discovery of built-in functions we provide a Function Builder in the
Table Panel. After selecting a non-list column cell, you can invoke it
by clicking on
[image: fx-button.png].
This should bring up the Function Builder which looks like this:

[image: FunctionBuilder2.png]

Select a function on the left hand side of the dialog - here, we’ve
selected the ABS function. Next to the list of functions, you can
specify one or more arguments. This can either be a column (selected
from the drop-down list) or a constant specified in the box below. If
you select a column, the value of that column (in the row containing the
formula) will be used, and the function result will be updated
dynamically when that value changes. Click Add to add an argument -
you can add one or more depending on how many arguments the function
accepts. At the bottom of the dialog is a preview of the current
formula. Under Apply to, you can select whether the formula will
apply to the current cell only, the cell selection, or the entire
column. Click OK when you are satisfied with the result, or Cancel to
discard any changes.

The Function Builder is a useful tool for discovery of the list of
built-in functions, which has the return type matching the data type of
the column. Arguments can either be selected from a list of named
columns, or constant values can be entered in a text entry field. A
major shortcoming at this time is that the Formula Builder won’t let you
compose functions with function calls as arguments. If you need the most
general functionality, please type the expression directly into a cell.

 




9.3. A Note for App Writers

It is relatively easy to add your own built-in formula functions. A
simple function can probably be implemented in 15 to 20 minutes. It can
then be registered via the parser and becomes immediately available to
the user. It will of course also show up in the drop-down list in the
Function Builder.
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10. Finding and Filtering Nodes and Edges

 


10.1. Search Bar

You can search for nodes and edges by column value directly through
Cytoscape’s tool bar. For example, to select nodes or edges with a
column value that starts with “STE”, type ste* in the search bar. The
search is case-insensitive. The * is a wildcard character that matches
zero or more characters, while ? matches exactly one character. So
ste? would match “STE2” but would not match “STE12”. Searching for
ste* would match both.

[image: searchbar3.png]

To search a specific column, you can prefix your search term with the
column name followed by a :. For example, to select nodes and edges
that have a “COMMON” column value that starts with “STE”, use
common:ste*. If you don’t specify a particular column, all columns
will be searched.

Columns with names that contain spaces, quotes, or characters other than
letters and numbers currently do not work when searching a specific
column. This will be fixed in a future release.

To search for column values that contain special characters you need to
escape those characters using a “\”. For example, to search for
“GO:1232”, use the query GO\:1232. The complete list of special
characters is:

+ - & | ! ( ) { } [ ] ^ " ~ * ? : \





Note: Escaping characters only works when searching all columns. It
currently does not work for column-specific searching. This will be
fixed in a future release.

 




10.2. Filters

The Select tab in the Control Panel can be used to create selection
expressions for selecting nodes and edges.

[image: select-panel2.png]

There are two tabs:


	On the Filter tab are narrowing filters, which can be combined into a tree.


	On the Chain tab are chainable transformers, which can be combined in a linear chain.




 


Narrowing Filters

Narrowing filters are applied to all the nodes and edges in the network, and are used to
select a subset of the nodes and edges based on user-specified
constraints. For example, you can find edges with a weight between 0 and
5.5, or nodes with degree less than 3. A filter can contain an arbitrary
number of sub-filters.

To add a filter click on the “+” button. To delete a filter (and all its
sub-filters) click the “x” button. To move a filter grab the handle
[image: filterhandle.png]
with the mouse and drag and drop the filter on its intended destination.
Dropping a filter on top of another filter will group the filters into a
composite filter.

 


Interactive Filter Application Mode

Due to the nature of narrowing filters, Cytoscape can apply them to a
network efficiently and interactively. Some filters even provide slider
controls to quickly explore different thresholds. This is the default
behavior on smaller networks. For larger networks, Cytoscape
automatically disables this interactivity. You can override this by
manually checking the Apply when filter changes box above the Apply
button:

[image: apply-automatically2.png]

The Apply button will re-apply the active filter. On the opposite side of the progress
bar is the cancel button, which will let you interrupt a long-running filter.

Cytoscape comes packaged with the following narrowing filters:

 




Column Filter

Column filters will match nodes or edges that have particular column
values. Depending on the column data type a variety of matching options are provided:


	Numeric Columns


	A slider is shown that represents the minimum and maximum values in the column.
Drag the two handles to select a range of values.


	The range values may also be entered manually.


	Options:


	is: Selects values that are inside the range.


	is not: Selects values that are outside the range.




[image: column-numeric.png]










	String Columns


	The text entered in the text box will be matched against the column values
depending on the following options.


	Options:


	contains: Selects values that contain the text.


	doesn’t contain: Selects values that do not contain the text.


	is: Selects values that match the text exactly (case-insensitive).


	is not: Selects values that do not match the text exactly (case-insensitive).


	regex: Selects values that match a regular expression using Java regular expression
syntax [https://docs.oracle.com/javase/8/docs/api/java/util/regex/Pattern.html]. This allows for much more
sophisticated matching than is provided by the above options.






	By default string matching is case insensitive. Case sensitive matching
requires the use of a regular expression that starts with “(?-i)”. For
example to match the text “ABC” in a case sensitive way use the
following regular expression: “(?-i)ABC”.

[image: column-string.png]










	Boolean Columns


	Boolean colums can only contain three values: true, false or blank.


	Options:


	true: Selects values that are true.


	false: Selects values that are false.




[image: column-boolean.png]










	List Columns


	Column filters for list columns are similar to their non-list counterparts, however
there is one additional option…


	any element: Matches if any value in the list matches the filter.


	each element: Matches only if all of the values in the list match the filter.




[image: column-list.png]









 




Degree Filter

The degree filter matches nodes with a degree that falls within the
given minimum and maximum values, inclusive. You can choose whether the
filter operates on the in-degree, out-degree or overall (in + out)
degree.

 




Topology Filter

The topology filter matches nodes having a certain number of neighbors
which are within a fixed distance away, and which match a sub-filter.
The thresholds for the neighborhood size and distance can be set
independently, and the sub-filter is applied to each such neighbor node.

The topology filter will successfully match a node if the sub-filter
matches against the required number of neighbor nodes.

 




Grouping and Organizing Filters

By default, nodes and edges need to satisfy the constraints of all your
filters. You can change this so that instead, only the constraints of at
least one filter needs to be met in order to match a node or edge. This
behavior is controlled by the Match all/any drop-down box. This
appears once your filter has more than one sub-filter. For example,
suppose you wanted to match nodes with column COMMON containing ste
or cdc, but you only want nodes with degree 5 or more, you’d first
construct a filter that looks like this:

[image: group1.png]

This filter will match nodes where COMMON contains ste and
cdc. To change this to a logical or operation, drag either of the
column filters by its handle
[image: filterhandle.png]
onto the other column filter to create a new group. Now change the
group’s matching behavior to Match any:

[image: group2.png]

You can also reorder filters by dropping them in-between existing
filters.

 






Chainable Transformers

The input to a chainable transformer is a set of nodes and edges, either the nodes and edges
that are currently selected in the network, or the output of a narrowing filter. Chainable
transformers can filter out nodes/edges, or include more nodes/edges. For example a chainable
transformer can add nodes that are neighbours of the nodes in the input.

Chainable filters are combined in an ordered list. The nodes and edges
in the output of a transformer become the input of the next transformer in the
chain. The first transformer in the chain gets its input from the current
selection or from a filter on the Filter tab. The output of the last
transformer becomes the new selection.

You can specify the input to the first transformer in the chain by selecting
a Start with, where Current selection refers to the nodes and
edges currently selected. You can also choose a narrowing filter, which
produces a different set of selected nodes and edges.

[image: chain-filter1.png]

Chainable transformer can be reordered by dragging one by the handle and
dropping it between existing transformer.

Cytoscape currently bundles the following chainable transformers:

 


Edge Interaction Transformer

This transformer will go through all the input edges and selectively add
their source nodes, target nodes, or both, to the output. This is useful
for adding nodes that are connected to edges that match a particular
filter.

Output options:


	Add (default): Automatically includes all input nodes and edges in
the output, and adds source or target nodes from input edges to
the output.


	Replace with: Does not automatically include input nodes and edges
in the output. Only outputs nodes that match the filter.




A sub-filter may be added as well. When a sub-filter is present the
source/target nodes must match the filter to be included in the output.

 




Node Adjacency Transformer

This transformer is used to add nodes and edges that are adjacent to the
input nodes. A sub-filter may be specified as well.

Note that pressing the Apply button repeatedly may cause the
selection to continuously expand. This allows adjacent nodes that are at
greater distances to be added.

Output options:


	Add (default): Automatically includes all input nodes and edges in
the output, and adds selected adjacent nodes and edges.


	Replace with: Only outputs the adjacent nodes/edges.




Select options:


	Adjacent nodes: Output nodes that are adjacent to the input nodes.


	Adjacent edges: Output edges that are adjacent (incident) to the
input nodes.


	Adjacent nodes and edges (default): Output both nodes and edges that
are adjacent to the input nodes.




Edge direction options. (Hidden by default, click the small arrow icon
to reveal.):


	Incoming: Only include adjacent nodes/edges when the adjacent edge
is incoming.


	Outgoing: Only include adjacent nodes/edges when the adjacent edge
is outgoing.


	Incoming and Outgoing (default): Ignore the directionality of
adjacent edges.




Sub-filter options. (Available when a sub-filter has been added.):


	Adjacent nodes (default): The sub-filter is only applied to
adjacent nodes. (Edges to the adjacent nodes are still included in
the output.)


	Adjacent edges: The sub-filter is only applied to adjacent edges.
(Nodes connected to the adjacent edges are still included in
the output.)


	Adjacent nodes and edges: Both the adjacent edge and its connected
node must match the filter. Note that for a filter to match an edge
and a node at the same time it should be a compound filter that is
set to “Match any (OR)”.




 






Working with Narrowing and Chainable Filters

The name of active filter appears in the drop-down box at the top of
Select panel. Beside this is the options button which will allow you
to rename, remove or export the active filter. It also lets you create a
new filter, or import filters.

[image: select-panel-options2.png]

 






10.3. Diffusion

Cytoscape’s Diffusion algorithm attempts to use a set of nodes and an entire interaction network to find the nodes most relevant to the original set.
Conceptually, Diffusion applies heat to each node in the set, and lets the heat flow through connecting edges to adjacent nodes.
It then produces a list of nodes ranked by the heat they accumulated. A node with many connections will tend to have a higher
ranking, and an isolated node will tend to have low rank (and thus be excluded from the resulting node set).

By default, Diffusion uses the set of selected nodes as the heat sources, with each node having the same initial heat. At the end of a Diffusion, Cytoscape leaves the top 90th percentile of hot nodes selected. It allows you to use the Results panel to select a higher or
lower percentile dynamically. It also stores the node’s initial heat as a node attribute in the “diffusion_input” column, and returns the heat and ranking values in the “diffusion_output_heat” and “diffusion_output_rank” columns.

An advanced Diffusion option allows you to specify initial heat values for each node via its “diffusion_input” attribute.

This figure shows the result of selecting the PHO4, GCR1 and ICL1 genes (via the search bar) and performing a Diffusion by either selecting Tools → Diffuse → Selected Nodes or right-clicking to Diffuse → Selected Nodes. Diffusion calculated the heat ranking of all 331 nodes in the network, and then selected the top 33.

[image: after_diffusion.png]

To select more than 33 nodes, move the Node Rank slider in the Diffusion Output Results Panel to the right or enter a number greater than 33 in the Current Rank field. You can also select nodes using a heat value cutoff by using the Range Column to select a column containing heat values. Finally, you can use the Visual Style chooser and Create button to extract the selected nodes into a new network.

You can execute Diffusion multiple times on a network, thereby creating multiple heat, output_heat and output_rank columns.

 




10.4. The Select Menu

The Select → Nodes and Select → Edges menus provide several
mechanisms for selecting nodes and edges. Most options are fairly
straightforward; however, some need extra explanation.

Select → Nodes → From ID List File… selects nodes based on node
identifiers found in a specified file. The file format is simply one
node id per line:

Node1
Node2
Node3
...
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11. Navigation and Layout

 


11.1. Basic Network Navigation

Cytoscape uses a Zoomable User
Interface [http://en.wikipedia.org/wiki/Zooming_User_Interface] for
navigating and viewing networks. ZUIs use two mechanisms for navigation:
zooming and panning. Zooming increases or decreases the magnification of
a view based on how much or how little a user wants to see. Panning
allows users to move the focus of a screen to different parts of a view.

 


Zoom

Cytoscape provides four mechanisms for zooming: toolbar buttons, menu options, keyboard shortcuts and the scroll wheel.

Use the zooming buttons located on the toolbar to zoom in
and out of the interaction network shown in the current network display.
Zoom icons are detailed below:

[image: image049.png]

From Left to Right:


	Zoom In


	Menu option: View → Zoom In


	Keyboard shortcut: Ctrl-Plus (Command-Plus on Mac OS X)





	Zoom Out


	Menu option: View → Zoom Out


	Keyboard shortcut: Ctrl-Minus (Command-Minus on Mac OS X)





	Zoom Out to Display all of Current Network


	Menu option: View → Fit Content


	Keyboard shortcut: Ctrl-0 (Command-0 on Mac OS X)





	Zoom Selected Region


	Menu option: View → Fit Selected


	Keyboard shortcut: Ctrl-9 (Command-9 on Mac OS X)




Using the scroll wheel, you can zoom in by scrolling up and zoom out by
scrolling downwards. These directions are reversed on Macs with natural
scrolling enabled (the default for Mac OS X Lion and newer versions).

 




Pan

There are two ways to pan the network:


	Left-Click and Drag - You can pan the network view by holding down the left mouse button and moving the mouse.


	Dragging Box on Network
Overview -
You can also pan the view by left-clicking and dragging the blue box in the overview panel in the lower part of the view.




 






11.2. Other Mouse Behaviors

 


Select


	Click the left mouse button on a node, edge or annotation to select that element.


	Hold down the Shift or Ctrl key (Command on Macs) and left-click a node, edge or annotation to add it to the selection. Doing the same on a selected element unselects it.


	Hold down the left mouse button on the canvas background and drag the mouse while holding down the Shift or Ctrl key (Command on Macs) to select groups of nodes/edges/annotations.


	Remember that the selection action (mouse click or drag-selection) only works if the Selection Mode for that element type (i.e. nodes, edges, annotations) is enabled. In order to enable or disable the selection of an element type, just toggle its corresponding button at the bottom of the network view (see image below) or use the options under the menu Select → Mouse Drag Selects.
[image: SelectionModeButtons.png]


	So if you don’t want any nodes to be selected, toggle the button [image: selection-mode-nodes.png] off.


	And if you don’t want any edges to be selected, toggle the button [image: selection-mode-edges.png] off.


	Likewise, if you don’t want any annotations to be selected, toggle the button [image: selection-mode-annotations.png] off.








 




Context

Click the right mouse button (or Ctrl+left mouse button on Macs) on a
node/edge to launch a context-sensitive menu with additional information
about the node/edge.

 




Node Context Menu

This menu can change based on the current context. For nodes, it
typically shows:


	Add


	Diffuse


	Edit


	Select


	Group


	Nested Networks


	Apps


	External Links


	Preferences




Edges usually have the following menu:


	Diffuse


	Edit


	Select


	Apps


	External Links


	Preferences




Apps can contribute their own items into node and edge context menus.
These additions usually appear in the Apps section of the context
menu.

 


Nested Network Node Context Menu


	Add Nested Network: Lets the user select any network in
Cytoscape as the current node’s nested network. If the current node
already has a nested network it will be replaced.


	Remove Nested Network: Removes the currently associated nested
network from a node. The associated network is not deleted. Only the
association between the node and the network is removed.


	Go to Nested Network: The current node’s nested network will be
the current network view and have the focus. Should a network view
for the nested network not exist, it will be created.




More information about nested networks can be found in the Nested
Networks
section.

 








11.3. Manual Layout

The simplest method to manually organize a network is to click on a node
and drag it. All of the selected nodes are moved together.

In addition to the ability to click on a node and drag it to a new
position, Cytoscape now has the ability to move nodes using the arrow
keys on the keyboard. By selecting one or more nodes using the mouse and
clicking one of the arrow keys (←, ↑, →, ↓) the selected nodes will move
one pixel in the chosen direction. If an arrow key is pressed while
holding the Shift key down, the selected nodes will move 15 pixels in the
chosen direction.

 




11.4. Node Layout Tools

The Tool Panel is available via the menu command View → Show Tool Panel, or via Layout → Node Layout Tools.

It contains several Node Layout Tools that can help to automate or fine tune a layout.

 


Scale

Adjust the Scale slider to change the length of edges.  The position of the nodes will be scaled, not the node sizes.
Node size can be adjusted using
Styles.
The images below show selected (yellow) nodes scaled to 50% of the default value.

Before

[image: NodeTools1.png]

After

[image: NodeToolsScaled.png]
 




Rotate

The Rotate function will change the orientation of the entire
network or a selected portion of the network. The images below show a
network with selected nodes rotated 90 degrees.

Before

[image: NodeTools1.png]

After

[image: NodeToolsRotated.png]

 




Align, Distribute and Stack

The Tool Panel contains buttons to set relative postions of nodes.

Align provides
different options for either vertically or horizontally aligning
selected nodes against a line. The differences are in what part of the
node gets aligned, e.g. the center of the node, the top of the node, the
left side of the node. Distribute evenly distributes selected nodes
between the two most distant nodes along either the vertical or
horizontal axis. The differences are again a function what part of the
node is used as a reference point for the distribution. Stack
vertically or horizontally stacks selected nodes with the full
complement of alignment options. The table below provides a description
of what each button does.


Align Options
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12. Styles

 


12.1. What are Styles?

One of Cytoscape’s strengths in network visualization is the ability to
allow users to encode any table data (name, type, degree, weight,
expression data, etc.) as a property (such as color, size of node,
transparency, or font type) of the network. A set of these encoded or
mapped table data sets is called a Style and can be created or
edited in the Style panel of the Control Panel. In this
interface, the appearance of your network is easily customized. For
example, you can:

Specify a default color and shape for all nodes.

[image: NodeShape.png]

Set node sizes based on the degree of connectivity of the nodes. You
can visually see the hub of a network…

[image: DegreeSize.png]

…or, set the font size of the node labels instead.

[image: DegreeLabelSize.png]

Visualize gene expression data along a color gradient.

[image: ColorGradient.png]

Encode specific physical entities as different node shapes.

[image: NodeShapeMapping.png]

Use specific line types to indicate different types of interactions.

[image: edge_types.png]

Control edge transparency (opacity) using edge weights.

[image: OpacityForEdges.png]

Control multiple edge properties using edge score.

[image: MultipleEdgeMapping.png]

Browse extremely-dense networks by controlling the opacity of nodes.

[image: OpacityForNodesAndEdges.png]

Show highly-connected region by edge bundling and opacity.

[image: Bundling.png]

Add photo/image/graphics on top of nodes.

[image: CustomGraphics1.png]
[image: CustomGraphics4.png]
[image: CustomGraphics5.png]

Cytoscape 3 has several sample styles. Below are a few examples of these
applied to the galFiltered.sif network :

[image: default_style.png]
[image: solid_style.png]
[image: ripple_style.png]
[image: universe_style.png]

 




12.2. Introduction to the Style Interface

The Style interface is located under the Style panel of the
Control Panel.

[image: StylesInterface.png]

This interface allows you to create/delete/view/switch between different
styles using the Current Style options. The panel displays the mapping
details for a given style and is used to edit these details as well.


	At the top of the interface, there is a drop-down menu for selecting
a pre-defined style. There is also an Options drop-down with
options to rename, remove, create and copy a Style, and an option to
create a legend for the selected Style.


	The main area of the interface is composed of three tabs, for Node,
Edge and Network.


	Each tab contains a list of properties relevant to the
current style. At the top of the list a Properties drop-down
allows you to add additional properties to the list.


	Each property entry in the list has 3 columns:


	The Default Value shows just that, the default value for
the property. Clicking on the Default Value column for any
property allows you to change the default value.


	Mapping displays the type of mapping currently in use for
the property. Clicking on the Mapping column for any
property expands the property entry to show the interface for
editing the mapping. Details on the mapping types provided
here.


	Bypass displays any style bypass for a selected node
or edge. Note that a node/edge or subset of nodes/edges must be
selected to activate the Bypass column. Clicking on the
Bypass column for selected node(s)/edge(s) allows you to
enter a bypass for that property for selected node(s)/edge(s).








The Default Value is used when no mapping is defined for a property,
or for nodes/edges not covered by a mapping for a particular property.
If a Mapping is defined for a property, this defines the style for
all or a subset of nodes/edges, depending on how the mapping is defined.
A Bypass on a specific set of nodes/edges will bypass and override
both the default value and defined mapping.

 




12.3. Introduction to Style

The Cytoscape distribution includes several predefined styles to get you
started. To examine a few styles, try out the following example:

Step 1. Load some sample data


	Load a sample session file: From the main menu, select File
→ Open…, and select the file sampleData/galFiltered.cys.


	The session file includes a network, some annotations, and
sample styles. By default, the style galFiltered Style
is selected. Gene expression values for each node are colored along
a color gradient between blue and yellow (where blue represents a
low expression ratio and yellow represents a high expression ratio,
using thresholds set for the gal1RGexp experiment bundled with
Cytoscape in the sampleData/galExpData.csv file). Also, node size
is mapped to the degree of the node (number of edges connected to
the node) and you can see the hubs of the network as larger nodes.
See the sample screenshot below:




[image: galFilteredSessionDefault.png]

Step 2. Switch between different styles

You can change the style by making a selection from the Current
Style drop-down list, found at the top of the Style panel.

For example, if you select Sample1, a new style will be applied to
your network, and you will see a white background and round blue nodes.
If you zoom in closer, you can see that protein-DNA interactions
(specified with the label “pd”) are drawn with dashed edges, whereas
protein-protein interactions (specified with the label “pp”) are drawn
with solid edges (see sample screenshot below).

[image: VizMapperSample1Style26.png]

Finally, if you select Solid, you can see the graphics below:

[image: VizMapperSolidStyle.png]

This style does not have mappings except node/edge labels, but you can
modify the network graphics by editing the Default Value for any
property.

Additional sample styles are available in the sampleStyles.xml file in
the sampleData directory. You can import the sample file from File →
Import → Styles from File….

 


List of Node, Edge and Network Properties

Cytoscape allows a wide variety of properties to be controlled. These
are summarized in the tables below.


Node Properties
                                
  
    
    13. Network Annotations
    

    

    

    
 
  

    
      
          
            
   


13. Network Annotations

Annotations in the form of shapes, images or text can be added to the network canvas.

The network canvas is made up of three transparent layers:


	Foreground layer


	Network layer


	Background layer




The middle Network layer contains nodes, edges and charts. The Foreground and Background
layers contain Annotations.

[image: layers.png]


13.1. Types of Annotations

There are five types of annotations available:


	Images (loaded from image files)


	Shapes (rectangles, triangles, etc…)

[image: type_shape.png]



	Text

[image: type_text.png]



	Bounded Text (combines text with a surrounding shape)

[image: type_bounded_text.png]



	Arrows (connects other annotations or nodes)

[image: type_arrow.png]








13.2. The Annotations Panel

The Annotations panel shows the annotations that are currently present on the foreground and
background layers. The panel allows you to create and delete annotations, select annotations,
move annotations up and down, move annotations between layers, and group annotations.

[image: annotations_panel.png]




13.3. Creating Annotations

At the top of the a Annotations Panel there are five buttons for creating each type of annotation.
Start by clicking the button for the type of annotation you would like to add.

[image: annotations_panel_buttons.png]

Alternatively, right click on the network canvas and select the annotation type under the Add menu.

[image: add_menu.png]


Shape, Bounded Text, Image


	Click the button for shape, bounded text or image annotation.


	Click the general location on the network canvas where the annotation should be placed.


	A dialog will appear that allows editing of the annotation properties. These properties can be edited
again after the annotation is created.


	Click the Ok button in the dialog.


	The annotation will appear on the canvas.


	The mouse cursor is automatically moved to the canvas and the annotation is in resize mode.


	Move the mouse cursor to resize the annotation. The annotation can be resized again later.


	Click the mouse again to stop resizing.







Text


	Click the button for text annotation.


	Click the general location on the network canvas where the annotation should be placed.


	A dialog will appear that allows editing of the text.


	Click the Ok button in the dialog.


	The annotation will appear on the canvas.







Arrow


	Creating an arrow annotation requires there to be at least one other annotation on the network canvas.


	Click the button for arrow annotation.


	Click on an annotation on the canvas, this will be the source annotation.


	Click on another annotation on the canvas or a node, this will be the destination.


	An arrow annotation appears connecting the source and destination.









13.4. Selecting Annotations

One or more annotations can be selected in the Annotations panel by clicking on them.

To be able to select annotations in the network canvas
Annotation Selection Mode must be enabled. Toggle the
[image: button_annotation_selection.png]
button at the bottom of the network view to enable/disable annotation selection mode.

[image: annotation_selection_mode.png]

When an annotation is selected it is surrounded by a yellow selection rectangle and 8 resize
handles are visible. The annotation can be moved by clicking on it with the mouse and dragging.
The annotation can be resized by clicking and dragging one of the handles.

[image: selected.png]

It is possible to select multiple annotations at the same time. Hold Ctrl on Windows,
or Command on Mac, while clicking on each of the annotations you would like to select.
This works both in the Annotations panel and on the network canvas. When multiple annotations
are selected they can be moved and resized at the same time.




13.5. Moving Annotations Backwards and Forwards

[image: annotations_panel_selected.png]

The Annotations panel displays a list of annotations on the foreground layer and a list of
annotations on the background layer.

Annotations that are towards the top of a list are drawn above annotations lower in the list.
To move an annotation within a layer select it and click the
[image: button_up.png] button to move it forward or the
[image: button_down.png] button
to move it backward. To move an annotation between layers select it and click the
[image: button_up_2.png]
to move it to the foreground layer or the
[image: button_down_2.png]
button to move it to the background layer.




13.6. Renaming Annotations

Each annotation has a name that is displayed in the Annotations Panel. These names are primarily
for organizational purposes and do not affect how the annotation is displayed on the canvas. To
rename an annotation double-click the annotation in the Annotations Panel and enter the new name.




13.7. Editing Annotations

To modify the properties of an annotation (eg, color, text) go to the Annotations panel,
right click the annotation, and select Modify Annotation… in the context menu.

[image: modify_menu.png]




13.8. Deleting Annotations

To delete annotations from the annotations panel select one or more annotations and click the
[image: button_trash.png] button.

To delete annotations from the network view right click an annotation and select Edit > Cut.




13.9. Grouping Annotations

Two or more annotations can be combined into a group. When grouped the annotations move and resize
as if they were a single annotation. Groups may be nested (a group may contain other groups).

[image: legend.png]

To create a group select two or more annotations and click the
[image: button_group.png] button. The group will be given a default
name that can be changed after the group is created. To un-group annotations select the group and click the
[image: button_ungroup.png] button.

A group may contain annotations from the foreground and background canvases. The group will show up in
both the foreground and background layers in the annotations panel.

[image: group_layers.png]

Note: Deleting a group will delete all the annotations contained within the group.
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14. App Manager

 


14.1. What are Apps?

Cytoscape’s capabilities are not fixed. They can be expanded with
apps. They can extend Cytoscape in a variety of ways. One app can
have the ability to import data from an online database. Another app
could provide a new method for analyzing networks. You can install apps
after you have installed Cytoscape. Most apps were made by Cytoscape
users like you.

If you’re familiar with Cytoscape 2.x, you probably know that Cytoscape
apps were called plugins. Starting in Cytoscape 3.0, we are calling
them apps. Cytoscape 2.x plugins cannot be used in Cytoscape 3.0.

 




14.2. Installing Apps

You can install apps through the App Store [http://apps.cytoscape.org]
or within Cytoscape. In this section, we’ll talk about installing apps
through Cytoscape. You can learn how to install apps through the App
Store here [http://apps.cytoscape.org/help/getstarted_app_install].

To install apps within Cytoscape, go to the menu bar and choose Apps →
App Manager…. At the top of the App Manager window, make sure you
have the Install Apps tab selected.

[image: AppManager]

There are four ways you can find apps:


	If you know the name of an app you’re looking for, enter it in the
Search field. The App Manager will list the apps whose names or
descriptions match the Search field in the middle panel.


	If you’re not sure what sort of app you need and want to see everything,
click the all apps folder. In the middle pane, you will see a
list of all the apps.


	If you want to install a collection of apps for a specific use case,
click on the collections folder. This will display the available
collections in the middle pane. A collection is simply an app that
installs other apps for a specific use case.


	If you have a general idea of what sort of app you’re looking for,
double-click on the apps by tag folder, then click on one of the
tags that interests you. The apps with that tag are listed in the
middle pane.




When you click on an app (or collection) in the middle panel, the
App Manager shows its short description and icon in the right panel.
If you want more information, click the View on App Store
button on the bottom-right. If you want to go ahead and install,
click the Install button.

If you’ve downloaded an app to your computer, you can install it by
clicking the Install from File button on the bottom-left.

 




14.3. Managing your Installed Apps

You can see a list of all apps you have installed by clicking the
Currently Installed tab at the top. When you click on an app in the
list, you’ll see a description of your app at the bottom. At the bottom,
you’ll see a couple buttons where you can:


	Uninstall an app. This deletes the app from your computer. If
you want to reinstall the app, you will have to find it again in the
Install Apps tab or find it in the App Store site and
reinstall it from there.


	Disable an app. This temporarily disables the app. The app stays
on your computer, but Cytoscape does not load it. You can enable the
app by first selecting the disabled app in the list, then click
Enable.




Note that uninstalling or disabling a collection will not uninstall or disable any apps installed by the collection.
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15. Automation Panel

The Automation Panel provides a simple command-line interface to
Cytoscape using the Commands API. It allows the user to type commands into
Cytoscape and see the results in a Reply Log.

Any app that registers commands will
be available through the Automation Panel. Commands are part of the more general
Cytoscape Automation feature,
which includes multiple ways of scripting Cytoscape execution.

The Automation Panel can be opened from View → Show/Hide Automation Panel.

[image: AutomationPanel.png]

The Automation Panel can also be used to read and execute script files.
Each line in the script file is a command that is sent to a app.
Script files may be entered on the Cytoscape command line using the “-S”
flag to Cytoscape, through the Tools → Run Script File… menu item,
or through Tools → Execute Command File menu item.

[image: RunScriptCommands.png]

Cytoscape commands consist of three parts: a command class, or
namespace; a command within that namespace; and a series of arguments or
options provided as a series of name=value pairs. For example, to
import an XGMML format file from the Command Line Dialog or a
command script, you would use:

network import file filePath="path-to-file"





where network is the namespace, import file is the command, and
there is only one argument: filePath=”path-to-file”. If there were
more arguments they would appear on the same line separated by spaces.

The Command Tool also uses the Command API to provide help. “help” by
itself will list all of the command classes (or namespaces) and “help “
followed by a namespace will list all of the commands supported by that
namespace. Details of a specific command are available by typing “help “
followed by the namespace and command (e.g. “help layout
force-directed”). The Command Tool registers the “command” namespace and
supports a single command: run, which takes a file argument. Here is the
help for the command run command from the command namespace:

help command run
       command run file=<File> 





Similarly, the help for the “network import file” example from above is:

help network import file
 network import file arguments:
 dataTypeList=<String>: List of column data types ordered by column index 
   (e.g. "string,int,long,double,boolean,intlist" or just "s,i,l,d,b,il")
 defaultInteraction=<String>: Default interaction type
 delimiters=<ListMultipleSelection [,,;, ,\t]>: Text Delimiters
 delimitersForDataList=<ListSingleSelection (\||\|/|,)>: 
   Text Delimiters for data list type
 file=<File>: Data Table file
 firstRowAsColumnNames=true|false: First row used for column names
 indexColumnSourceInteraction=<int>: Column for source interaction
 indexColumnTargetInteraction=<int>: Column for target interaction
 indexColumnTypeInteraction=<int>: Column for interaction type
 NetworkViewRendererList=<ListSingleSelection ()>: Network View Renderer
 RootNetworkList=<ListSingleSelection (-- Create new network collection 
   --|Network)>: Network Collection
 startLoadRow=<int>: Start Load Row
 TargetColumnList=<ListSingleSelection ()>: Node Identifier Mapping Column
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16. Merge

Cytoscape allows for merging of both network and table data, through
Tools → Merge.

 


16.1. Merge Networks

The Advanced Network Merge interface is available from Tools →
Merge → Networks… and allows for merging of two or more networks.

[image: Advanced NetworkMerge]

 


Basic Operations


	With the buttons select either “union”, “intersection”
or “difference”.


	Networks available for merge are listed under Networks to merge.
Select a network from the list and click the right arrow to transfer
the network to Selected networks. Click Merge to continue.
The merged network will be displayed as a separate network.




 




Advanced Options

The Advanced Network Merge interface includes an expandable
Advanced Network Merge panel, where you can specify the details of
how to merge the networks. The options available here are:


	Matching columns: This specifies the network columns that should
be used for merging. Typically, the “name” column or some other
column containing identifier information is used here.


	How to merge columns?: A table lets the user specify for each of
the individual network columns, what the corresponding column in the
merged network should be named and its data type.




[image: Advanced Network Merge Options]
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17. NetworkAnalyzer

NetworkAnalyzer computes a comprehensive set of topological parameters
for undirected and directed networks, including:


	Number of nodes, edges and connected components.


	Network diameter, radius and clustering coefficient, as well as the
characteristic path length.


	Charts for topological coefficients, betweenness, and closeness.


	Distributions of degrees, neighborhood connectiveness, average
clustering coefficients, shortest path lengths, number of shared
neighbors and stress centrality.




NetworkAnalyzer also constructs the intersection, union and difference
of two networks. It supports the extraction of connected components as
separate networks and the removal of self-loops.

 


17.1. Network Analysis

 


Analyze Network

To run NetworkAnalyzer, select Tools → NetworkAnalyzer → Network
Analysis → Analyze Network.

[image: NetworkAnalyzer.png]

The NetworkAnalyzer will determine whether your network contains
directed or undirected edges. At this point, you can choose to ignore
edge direction information.

When results are calculated, they will appear in the Results Panel.

[image: NetworkAnalyzerResults.png]

The results have multiple tabs. Details on the network parameters can be
found
here [http://med.bioinf.mpi-inf.mpg.de/netanalyzer/help/2.7/index.html#complex].


	Simple Parameters


	Node Degree Distribution


	Avg. Clustering Coefficient Distribution


	Topological Coefficients


	Shortest Path Distribution


	Shared Neighbors Distribution


	Neighborhood Connectivity Distribution


	Betweenness Centrality


	Closeness Centrality


	Stress Centrality Distribution




You can also save the statistics for later use by using the Save
Statistics button.

 




Analyze Subset of Nodes

An exhaustive topological analysis of very large networks can be a time
consuming task. The computation of local parameters for the nodes is
significantly faster than the computation of global (path-related)
parameters. Examples of local parameters are node degree, neighborhood
connectivity, topological and clustering coefficients. Betweenness and
closeness centralities, as well as stress, are global parameters.

NetworkAnalyzer
provides the Analyze Subset of Nodes option for computing local
parameters for a subset of nodes. If one or more nodes in the network
are selected before starting an analysis, only the sub-network induced
by the selected nodes is analyzed. Moreover, only local parameters are
computed. Shared neighbors distribution and shortest path lengths
distribution, among others, are not displayed in the results.

 




Batch Analysis

The Batch Analysis option is used to perform topological analysis on
all networks stored in specific directory, using all possible
interpretations for every network. Batch analysis consists of three
simple steps:


	Selecting directories: The user selects the input and
output directories. The input directory should contain network files
that can be loaded into Cytoscape. Sub-directories of the input
directory are not considered. The output directory is the one that
will contain all analysis results after the batch analysis. In order
to avoid file overwriting, NetworkAnalyzer requires that the output
directory is empty (contains no files) before the batch
analysis starts.


	Analysis: NetworkAnalyzer scans the input directory and loads
all supported networks into Cytoscape, one at a time. Each loaded
network is inspected and then it is analyzed considering all
possible interpretations for it. The analysis step is complete after
all networks are analyzed. Note that depending on the number of
networks and their sizes, this might be a very time-consuming step.


	Inspection of results: After the analysis is complete, the
button Show Results is enabled, and it displays the
results dialog. The dialog contains a table of all topological
analyses performed. Every row in the results table lists the loaded
network, its interpretation and the resulting network statistics
file that was saved in the output directory. By clicking on a
network name and on statistics file name, the user can load the
network and topology analysis results, respectively.




 




Load Network Statistics

Existing network statistics can be loaded from a file saved previously
in NetworkAnalyzer.

 




Plot Parameters

The Plot Parameters dialog offers a possibility to plot two
parameters against each other. The parameters to be plotted can be
chosen from two drop-down menus. The Table Column 1 menu provides
the values for the domain/category axis, and the Table Column 2 menu
specifies the values for the range/value axis. The plot is updated each
time a different parameter is selected in one of the menus.

 




Generate Style from Statistics

NetworkAnalyzer computed parameters can be visualized as node/edge size
and color, if the Store node / edge parameters in node / edge table
option in NetworkAnalyzer Settings is enabled. Parameters loaded
from a .netstats file cannot be visualized because the network itself is
not stored in the network statistics file. If, after performing
topological analysis, the network is modified by introducing or removing
nodes or edges, it is recommended (and sometimes required) to run
NetworkAnalyzer again before visualizing any parameters.

The visualization is initiated by the Generate Style from
Statistics… menu option. There are two ways of mapping computed
parameters.


	Map to node / edge size: The computed parameter is mapped to the
size of the nodes or edges. Mapping can be straight or inverse, that
is, low parameter values can be mapped to small sizes or to
large sizes. The smallest node size is set to 10 and the largest one
to 100. Regarding edges, size reflects the edge line width and
varies between 1 and 8. Refer to the
Styles
section for details.


	Map to node / edge color: A computed parameter is mapped to the
color of the nodes or edges. Two mapping styles are possible -
mapping low parameter values to bright colors or to dark colors. By
default, the brightest color is green and the darkest color is red.
The mapping also uses a middle (intermediate) color, which allows
for fine-grained perception of differing values through the
color gradient. The default middle color is yellow.




[image: NetworkAnalyzer_VisualizeParameters.png]

 




NetworkAnalyzer Settings

The following settings can be configured by the user:


	Store node / edge parameters in node / edge table: For every
node in a network, NetworkAnalyzer computes its degree (in- and
out-degrees for directed networks), its clustering coefficient, the
number of self-loops, and a variety of other parameters.
NetworkAnalyzer also computes edge betweenness for each edge in
the network. If the respective options are enabled, NetworkAnalyzer
can stores the computed values as columns of the corresponding nodes
and edges. This enables the users to use the values in Styles or to
select nodes or edges based on the values. A complete list of the
computed node and edge columns is available
here [http://med.bioinf.mpi-inf.mpg.de/netanalyzer/help/2.7/index.html#attributes].


	Use expandable dialog interface for the display of network
statistics: If this option is enabled, analysis results are
presented in a window in which all charts are placed below each
other in expandable boxes. If this option is disabled, analysis
results are presented in a window that contains tabs for the group
of simple parameters and for every complex parameter (default).
Users who wish to simultaneously view two or more complex parameters
of one network, should enable this option.


	NetworkAnalyzer allows the user to change the default colors of
parameter visualization.


	Background color for parameter visualization: The color of
the background in the network view. It is initially set to the
default Cytoscape background color.


	Bright color to map parameters: This color defines the
brightest color that parameters can be mapped to. By default its
value is green.


	Middle color: This color defines the intermediate color,
that parameters can be mapped to. By default its value
is yellow.


	Dark color: This color defines the darkest color that
parameters can be mapped to. By default its value is red.






	Location of the help documents: URL of the original help web
page for NetworkAnalyzer. This also enables the local download and
storage of this help page.




 






17.2. Subnetwork Creation

NetworkAnalyzer allows for the creation of sub-networks of connected
components. The user selects a number of connected components from a
list and each selected component is visualized as a sub-network. To create
sub-networks from connected components, select Tools → NetworkAnalyzer → Subnetwork Creation → Extract Connected Components.

[image: NetworkAnalyzer_ConnectedComponents.png]

 




17.3. NetworkAnalyzerDemo: Computation and Visualization of Topological Parameters and Centrality Measures for Biological Networks

Yassen Assenov1, Nadezhda Doncheva1, Thomas Lengauer1, and Mario Albrecht1

1 Department of Computational Biology and Applied Algorithmics, Max Planck Institute for Informatics, Campus E1.4, 66123 Saarbrücken, Germany

NetworkAnalyzer is a versatile and highly customizable Cytoscape plugin that requires no expert knowledge
in graph theory from the user. It computes and displays a comprehensive set of topological parameters and
centrality measures for undirected and directed networks, which includes the number of nodes, edges, and
connected components, the network diameter, radius, density, centralization, heterogeneity, clustering
coefficient, and the characteristic path length. In addition, NetworkAnalyzer shows charts of the distribution
of node degrees, neighborhood connectivities, average clustering coefficients, and shortest path lengths.
NetworkAnalyzer also contains extra functionality, for instance, for constructing the intersection or union of two networks.

The NetworkAnalyzer plugin and a comprehensive online documentation with a tutorial are available at http://med.bioinf.mpi-inf.mpg.de/networkanalyzer/.

Data keywords: network, graph, topology

Cytoscape keywords: Network Analysis
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18. Cytoscape Preferences

 


18.1. Managing Properties

The Cytoscape properties editor, accessed via Edit → Preferences →
Properties…, is used to specify default properties. Any changes made
to these properties will be saved in .props files under the
CytoscapeConfiguration subdirectory of the user’s home directory.

Cytoscape properties are configurable using the Add, Modify and Delete
buttons as seen below.

[image: Preferences_cy3.png]

App properties may also be edited in the same way as editing Cytoscape
properties. For example, to edit the properties of Linkout, select
‘linkout’ from the combobox of the Preferences Editor. Some apps may
store properties inside session files in addition to (or instead of)
storing them in the CytoscapeConfiguration directory.

[image: Preferences_linkout.png]

 




18.2. Managing Bookmarks

Cytoscape contains a pre-defined list of bookmarks, which point to
sample network files located on the Cytoscape web server. Users may add,
modify, and delete bookmarks through the Bookmark manager, accessed by
going to Edit → Preferences → Bookmarks….

[image: Preferences_bookmarks.png]

There are currently several types of bookmarks (based on data
categories), including network and table. Network bookmarks are URLs
pointing to Cytoscape network files. These are normal networks that can
be loaded into Cytoscape. Table bookmarks are URLs pointing to data
table files.

 




18.3. Managing Proxy Servers

You can define and configure a proxy server for Cytoscape by going to
Edit → Preferences → Proxy Settings….

[image: Preferences_proxy.png]

After the proxy server is set, all network traffic related to loading a
network from URL will pass through the proxy server. Cytoscape apps use
this capability as well. The proxy settings are saved in
cytoscape3.props. Each time you click the OK button after making a
change to the proxy settings, an attempt is made to connect to a well
known site on the Internet (e.g., google.com) using your settings. For
both success and failure you are notified and for failure you are given
an opportunity to change your proxy settings.

If you no longer need to use a proxy to connect to the Internet, simply
set the Proxy type to “direct” and click the OK button.

 




18.4. Managing Group Settings

The configuration of Cytoscape group view may also be edited through
Edit → Preferences → Group Preferences….

[image: Preferences_groups.png]

Note that Group Preferences apply to node groups established after the group preferences are set. They do not apply to groups that already exist.

The Group Preferences dialog provides access to three Group View Settings and all of the Attribute Aggregation Settings.
There are two interacting settings involved in the group view and group interaction:


	how an expanded group appears


	what happens when a node (group member or group node) is double-clicked


	what appears inside of a group node when it is collapsed





Group View Settings

The following node visualization options are available:


	None: No specific visualization – just do expand/contract, but don’t treat the expanded group special in any way


	Compound Node: Show the group node as an area surrounding the member nodes, but position it behind the member nodes to allow direct selection of each of the members.  If you move a node within this area, you may need to resize the area to encompass the newly positioned member node. Moving the group node will cause all member nodes to move with it.  There are visual styles that allow you to change the color, shape and padding for the compound node.


	Show Group Node: When the group is expanded, show the group node as an additional node and add “member edges” between the group node and each of the member nodes.  This is useful, for example, for complexes where it may be important to show a group node (the entire complex) at the same time as group member nodes (each individual protein).


	Single Node:  Show the group node as an area surrounding the member nodes, but put it in front of the member nodes so that the member nodes can not be selected or moved individually.




If you set the Double-Click action to something other than Expand/Contract, the groups won’t collapse on double-click, which may be appropriate for displaying group nodes that contain other nodes (i.e., the Compound Node visualization or Single Node visualization).




Attribute Aggregation Settings

Attribute aggregation provides an automated way for a group to aggregate all of the attributes of its children.  Since the columns in a Cytoscape network must all be of the same type, a group can’t simply create a list of integers to aggregate the integer columns of its members – the right approach to aggregating the attributes of group members will obviously depend on the application.  Cytoscape allows you to set the default aggregation approach for each type of column: Integer, Long, Double, String, Boolean, String List, Integer List, Long List, or Double List in the Default Aggregation Settings section.  In general, the user is provided with a list of some common aggregations.  For example, Integer aggregations include Average,  Minimum Value, Maximum Value, Median Value or Sum.

In addition, users can indicate that a specific column should use an aggregation approach different from the default by looking at Aggregation Overrides.




Grouping Tips

The Show collapsed node as a Nested Network checkbox determines the contents of a grouping node when its member nodes are hidden. If it is checked, the group node contains a graphic of the laid out member nodes. For the Compound Node visualization, this box should remain unchecked so the grouping node can appear as a background to member nodes.

Attribute aggregation only occurs when the group is collapsed or when the group visualization is changed (e.g., from Single Node to Compound Node).






18.5. Managing OpenCL Settings

You can choose between one or more OpenCL drivers installed on your system by going to
Edit → Preferences → OpenCL Settings….

[image: Preferences_opencl.png]

OpenCL is a library that enables Cytoscape to use your system’s graphics processing unit (GPU)
to accelerate certain layouts and other calculations. If no choices are presented, consult
the support web page for your system’s graphics card.







          

      

      

    

  

  
    
    19. Linkout
    

    

    

    
 
  

    
      
          
            
   


19. Linkout

Linkout provides a mechanism to link nodes and edges to external web
resources within Cytoscape. Right-clicking on a node or edge in
Cytoscape opens a popup menu with a list of web links.

By default, Cytoscape includes a number of links such as
Entrez, SGD and Google, as well as a number of species-specific
links. In addition to the default links, users can customize the
External Links menu and add (or remove) links by using the Cytoscape
Preferences Editor (found under Edit → Preferences → Properties…
in the linkout group).

External links are listed as ‘key’-‘value’ pairs in the
editor where Property Name specifies the name of the link and
Value is the search URL. Linkout menus are organized in a
hierarchical structure that is specified as part of the key. Linkout key terms
specific to nodes start with the keyword nodelinkouturl; for edges
this is edgelinkouturl.

For example, the following entry:

nodelinkouturl.Model Organism DB.SGD (yeast)=http://www.yeastgenome.org/cgi-bin/locus.fpl?locus=%ID%





places the SGD link under the Model Organism DB submenu. This link will
appear in Cytoscape as:

[image: Figure1_linkout_Cy3.png]

In a similar fashion one can add new submenus.

The %ID% string in the URL is a place-holder for the node label.
When the popup menu is generated this marker is substituted with the
node label. In the above example, the generated SGD link for the YNL050C
protein is:

http://www.yeastgenome.org/cgi-bin/locus.fpl?locus=YNL050C





If you want to query based on a different column, you need to specify a
different node label using Styles.

For edges the mechanism is much the same; however here the placeholders
%ID1% and %ID2% reflect the source and target node label
respectively.

Currently there is no mechanism to check whether the constructed URL
query is correct and if the node label is meaningful. Similarly, there
is no ID mapping between various identifiers. For example, a link to
NCBI Entrez from a network that uses Ensembl gene identifiers as node
labels will produce a link to Entrez using the Ensembl ID, which results
in an incorrect link. It is the user’s responsibility to ensure that the
node label that is used as the search term in the URL link will result
in a meaningful link.

 


19.1. Adding and Removing Links

The default links are defined in the linkout.props file contained in the
CytoscapeConfiguration directory. These links are normal Java properties and can
be edited directly via text editor or by using the Cytoscape Configuration Editor (Edit → Preferences → Properties…) and
selecting linkout (shown below).

[image: Figure2_linkout26.png]

In addition, new links can be defined when starting Cytoscape from
command line by specifying individual properties. The formatting of the
command is cytoscape.sh -P [context_menu_definition]=[link].
context_menu_definition specifies the context menu for showing the
linkout menu item. The structure of this definition is nodelinkouturl or edgelinkouturl followed by
“.” and followed by the “.”-separated menu hierarchy.

For instance this command:

cytoscape.sh -P nodelinkouturl.yeast.SGD=http://db.yeastgenome.org/cgi-bin/locus.pl?locus\=%ID%





will add this menu item:

[image: Figure3_linkout26.png]

To remove a link from the menu, simply delete the property using Edit
→ Preferences → Properties… and selecting commandline. Linkouts
added in the command line will be available for the running instance of
Cytoscape.
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20. Panels

Panels are floatable/dockable panels designed to cut down on the number of pop-up windows within Cytoscape
and to create a more unified user experience.

There are five panels that can be visible or hidden.


	Control Panel (left)


	Tool Panel (bottlom left)


	Table Panel (bottom right)


	Results Panel (right)


	Automation Panel (bottom)




Each panel typically contains multiple tabs. For example the Control Panel contains at a minumum the Network,
Style, Select and Annotation tabs. The Table Panel contains the Node Table, Edge Table and
Network Table tabs. Analysis results from Network Analyzer (Tools → Network Analysis → Analyze Network)
are shown in Results Panel. Installed Apps may add additional tabs.

[image: DockWindow-v3_7_0.png]

The user can then choose to resize, hide or float Panels. For example, in the screenshot below, the Control, Table
and Results panels are floating:

[image: FloatPanels-v3_7_0.png]

 


20.1. Basic Usage

All panels can be shown or hidden using the View → Show/Hide functions.

[image: cytopanel-menu-items.png]

By default, only the Control Panel and the Data Panel will be shown. The Results Panel may appear,
depending on the mix of Cytoscape apps that you currently have installed. The Tool Panel will appear when
you select the following commands under the Layout menu: Rotate, Scale, and Align and Distribute.

In addition, Panels can be floated or docked using icon buttons at the top right corner of each Panel.
The Float Window control
[image: FloatWindow-v31.png]
will undock any panel which is useful when
you want assign the network as much screen space as possible. To dock the window again, click the
Dock Window icon
[image: DockWindow.png]
. Clicking the Hide Panel
icon
[image: HideWindow.png]
will hide the panel; this can be shown again by choosing
View → Show and selecting the relevant panel.
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21. Rendering Engine

 


21.1. What is Level of Detail (LOD)?

Cytoscape 3.0 retains the rendering engine found in version 2.8. It is
to be able to display large networks (> 10,000 nodes), yet retain
interactive speed. To accomplish this goal, a technique involving
level of detail (LOD) is being used. Based on the number of objects
(nodes and edges) being rendered, an appropriate level of detail is
chosen. For example, by default, node labels (if present) are only
rendered when less than 200 nodes are visible because drawing text is a
relatively expensive operation. This can create some unusual behavior.
If the screen currently contains 198 nodes, node labels will be
displayed. If you pan across the network, such that now 201 nodes are
displayed, the node labels will disappear. As another example, if the
sum of rendered edges and rendered nodes is greater than or equal to a
default value of 4000, a very coarse level of detail is chosen, where
edges are always straight lines, nodes are always rectangles, and no
anti-aliasing is done. The default values used to determine these
thresholds can be changed by setting properties under Edit |
Preferences | Properties….

Low LOD vs High LOD


Levels of Detail

 	Network with Low LOD                                                            	Network with High LOD                                                       

 	 	 




With low LOD values, all nodes are displayed as square and anti-aliasing
is turned off. With high LOD values, anti-aliasing is turned on and
nodes are displayed as actual shape user specified in the Style.

 


Parameters for Controlling LOD

NOTE: The greater these thresholds become, the slower performance
will become. If you work with small networks (a few hundred nodes),
this shouldn’t be a problem, but for large networks it will produce
noticeable slowing. The various thresholds are described below.


LOD Thresholds
 	Parameter                          	Description                                                                                                                                  

 	render.coarseDetailThreshold  	If the sum of rendered nodes and rendered edges equals to or exceeds this number, a very coarse level of detail will be chosen and all other detail parameters will be ignored. If the total number of nodes and edges is below this threshold, anti-alias will be turned on; this value defaults to 4000. 

 	render.nodeBorderThreshold 	If the number of rendered nodes equals to or exceeds this number, node borders will not be rendered; this value defaults to 400.  

 	render.nodeLabelThreshold     	If the number of rendered nodes equals to or exceeds this number, node labels will not be rendered; this value defaults to 200.      

 	render.edgeArrowThreshold  	If the number of rendered edges equals to or exceeds this number, edge arrows will not be rendered; this value defaults to 600.   

 	render.edgeLabelThreshold     	If the number of rendered edges equals to or exceeds this number, edge labels will not be rendered; this value defaults to 200.      



When printing networks or exporting to formats such as PostScript, the
highest level of detail is always chosen, regardless of what is
currently being displayed on the screen.
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22. Export Your Data


22.1. Raw Data Export

[image: export_menu_37.png]

To use data from Cytoscape networks in an external application, the data has to be exported.
As a Cytoscape network consists of a number of different types of data, there are options
in Cytoscape for each exportable data type. These options (Network, Table, Styles) can be found on the
File → Export submenu (shown above).

 


Network Data Exchange (NDEx) Public Database

The Network to NDEx and Collection to NDEx options are used to store a network on a public NDEx server. You can use an NDEx server as a cloud-based store for your networks, as a means of sharing networks with collaborators, or to archive networks for publication. To store a network, you must have an NDEx account, which you can create by visiting the NDEx Public Server [http://ndexbio.org] website.

The Network to NDEx option saves only the currently selected network to your NDEx account. Such networks are suitable for processing by other applications and web services, as they contain only the nodes and edges in the selected network – other networks and the nodes and edges unique to them are not written. If you import this network (using the Cytoscape Search bar), only the single network will be loaded.

The Collection to NDEx option saves all networks in the collection containing the currently selected network. If you import this collection (using the Cytoscape Search bar), the entire collection will be loaded. This option is closest to saving an entire Cytoscape session, except that only the current collection is saved.

When you select either option, the CyNDEx-2 Browser dialog will appear and enable you to provide metadata that will be displayed during subsequent NDEx searches. To save a network, you must add an NDEx account profile to the CyNDEx-2 Browser (by filling out the profile form reachable by clicking on the Anonymous credential in the upper right), and then make it current.

[image: ndex_save.png]

You can set the name of your network by editing the Network Name attribute at the bottom. The Update Existing Network option enables you to overwrite an existing NDEx network if you have permission. If you choose to make your network public, you must fill in the Version and Description attributes. Choose the Save as Public option to enable collaborators to load your network.

Menu actions have also been added to the network and collection context menus in the Cytoscape Network panel, as another method of accessing the network save dialog.

[image: ndex_context_menus.png]

When the export to NDEx is complete, you will be given an opportunity to capture the network’s UUID in your clipboard. The UUID is suitable for e-mailing to colleagues so they can load your network via their Cytoscape Search bar (provided you selected the Save as Public option). For more sharing options, see the NDEx Public Server [http://ndexbio.org] website.

[image: ndex_save_done.png]

Further information on NDEx is available at the NDEx Informational/Doc website [http://home.ndexbio.org].




Network

[image: network_export_dialog.png]

The Network option is used to export
network data. Network data includes the nodes and edges in the network, and also
will include data attributes and visual information if the chosen format supports it
(like XGMML). Network data can be exported in a number of formats, including:


	SIF (Simple Interaction Format)


	NNF (Nested Network Format)


	XGMML


	GraphML


	PSI-MI Level 1 and 2.5


	Cytoscape.js JSON (can be used with Cytoscape.js, a tool described in future sections)


	CX JSON (for Cytoscape Cyberinfrastructure network exchange)




The default format is SIF, which is a simple tab-delimited network format that provides
node names and edge interactions only. You can choose the format using the dialog drop-down box.
A file name is automatically suggested based on the network name and selected format, with the file path
defaulting to the current working directory. You can change the suggested file name/path using the
text box or Browse button. Press OK to export with the selected options.




Table

[image: table_export_dialog.png]

The Table option is used to export any of the data tables that are available
in the current Cytoscape session. This includes the node, edge, and network tables
that can be seen in the Table Browser, as well as any unassigned tables. The only
currently supported file format currently for export is CSV (comma-separated value).

The export dialog for Table has only two selectable options - the table to export
and the file name (file type is always CSV). A file name is suggested based on the
name of the selected table with the path defaulting to the current working directory.
As in Network, the suggested file name can be changed using the Browse button or the
text field. Press OK to export the selected table with the given file name.




Styles

[image: styles_export_dialog.png]

The Styles option is used to export one or more visual styles available in the current Cytoscape session. Supported formats include Style XML (which can be imported by 3.x versions of Cytoscape) or Cytoscape.js JSON (which can be used with Cytoscape.js, described in future sections).

Style export has three options - the export format (as described above), the style(s) to export, and the file name (a suggestion will be made based on the current directory and file type). As in Network → Table, the suggested file name can be changed using the Browse button or the text field. The list of styles is a multiple-selection list - one or more can be selected using Ctrl/Cmd-click (to select multiple discontiguous elements) or Shift-click (to select a contiguous element range). Press OK to export all selected styles with the given file path.

 






22.2. Exporting for Publication

When you finish your data analysis and visualization, you can
publish your data to share the results. Cytoscape has several options to
do this, with most options suitable for Cytoscape users and other options
suitable for programmers wanting to create unusual or complex network
viewers. These are further explained below.


	An NDEx network


	A session file


	A static image


	An interactive web application


	CyNetShare [http://idekerlab.github.io/cy-net-share/]


	Full web application


	Simple network view (for web application developers)








 


As an NDEx Network

The easiest way to share your results with others is to save your network in the NDEx Public Database by using the Network to NDEx or Collection to NDEx options. When you save your network, you will receive a UUID (e.g., 50e3dff7-133e-11e6-a039-06603eb7f303) that you can e-mail to collaborators for use in their own Cytoscape Search bar (provided you exported using the Save as Public option – see the Save as Public option.)

NDEx also has options that enable you to:


	generate a DOI suitable for use in publications


	create an anonymous sharable link (similar to a Google Doc shared link)


	create interest groups and specific sharing within NDEx




For more information on NDEx publishing and sharing features, see the Publishing in NDEx [http://home.ndexbio.org/publishing-in-ndex/] and Sharing Networks in NDEx [http://home.ndexbio.org/obtaining-and-granting-access-to-a-network/] tutorials.

 




As a Session File

Another easy way to share your results with others is simply saving
everything as a session file (which is a zipped session archive). You
can save your current session by clicking the Save Session icon. You
can save to a thumb drive, a shared file system, or even a cloud drive
directory such as Dropbox. If you save to a shared drive, beware not
to have two people work on the same session file with Cytoscape at the
same time, as unpredictable results may occur.

 




As a Static Image

[image: image_export_dialog.png]

Cytoscape can generate publication-quality images from network views. By
selecting File → Export as Image…, you can
export the current network view into the following formats:


	JPG


	PNG


	PS (Post Script)


	SVG


	PDF




The image export dialog has a variable number of options based on the file format selected, with file type and file name always being selectable. PNG and JPEG have options for scaling, while other formats only have a single option, Export Text as Font. The file name is suggested based on the name of the selected table with the path defaulting to the current working directory. As in raw data export, the suggested file name can be changed using the Browse button or the text field. Press OK to export an image with the given file name and parameters.

We recommend using PDF for publications because it is a standard
vector graphics format, and it is easy to edit in other applications
such as Adobe Illustrator.

 


Known Issues

For PDF export, there is an option to Export text as font.
This option does not work for two-byte characters such as Chinese or
Japanese. To avoid corrupted texts in the exported images, please
uncheck this option when you publish networks including those
non-English characters.

 






As an Interactive Web Application (New in 3.2.0)

The Web is an excellent platform for data sharing and collaboration, and
Cytoscape provides a number of ways to publish your network on the web,
with each choice representing tradeoffs between ease, simplicity, and
customization options. All solutions leverage the cytoscape.js drawing
library, and so enable not only viewing but also Cytoscape-style
interactive browsing of networks and attributes.

The simplest choice is
CyNetShare,
where you save your network (and optionally a style) on a public file
system, then interactively view the network in a browser. Like Google
Maps, you can generate and publish a URL that allows collaborators to
also view your network.

Alternatively, Cytoscape can generate an entire web site showing a
single page containing the viewer with your network pre-loaded. You can
load this directly onto your own web server to become part of your web
site.

Finally, Cytoscape can generate the skeleton of a web site for further
customization by
JavaScript [https://en.wikipedia.org/wiki/JavaScript]
programmers.

These features are available as Export menu items under the File menu,
and are described in sections below.

For example, here is a network in Cytoscape:

[image: WebExportOriginal_v3_3_3.png]

Here is the same network as an interactive web visualization:

[image: web_export_fullexport.png]

Note that web browsers can render small networks (e.g., 1000 nodes)
quickly and effectively, but attempting to render large ones (e.g., 5000
nodes) will take a very long time.

A word about exporting styles to interactive web
applications: Our web applications are based on the cytoscape.js
display library, which renders a subset of Cytoscape styles. For more
information, see the Export Styles to Cytoscape.js section below.

 


Sharing via CyNetShare

CyNetShare [http://idekerlab.github.io/cy-net-share/]
is a browser-based web application that renders JSON-formatted networks
and attributes saved in public directories. Optionally, you can specify
visual styles that the web application will use to draw your network as
it appears in Cytoscape.
CyNetShare [http://idekerlab.github.io/cy-net-share/]
is similar to Google Maps in that once you have loaded your network and
have tweaked its appearance to suit your needs, you can have
CyNetShare [http://idekerlab.github.io/cy-net-share/]
generate a new URL that you can e-mail or post as a link on your own web
site. That URL will bring up
CyNetShare [http://idekerlab.github.io/cy-net-share/]
preloaded with your network for anyone to see.

To use
CyNetShare [http://idekerlab.github.io/cy-net-share/]:


	Select File → Export → Network to File… to export your
network to a public directory. Choose the Cytoscape.js
JSON (*.cyjs) export file format.


	Optionally, select File → Export → Style… to export your
style settings. Choose the Style for cytoscape.js (*.json) export
file format.


	Use your public directory system to determine direct URLs for the
files you exported.


	Start CyNetShare [http://idekerlab.github.io/cy-net-share/]


	Enter the network’s URL as the Graph URL.


	Optionally, enter the style’s URL.


	Click the Visualize button.




The
CyNetShare [http://idekerlab.github.io/cy-net-share/]
User Guide is provided on the
CyNetShare [http://idekerlab.github.io/cy-net-share/]
web page:


	CyNetShare [http://idekerlab.github.io/cy-net-share/]




Note that if you specify a style URL, the style is added to the list of
styles available in
CyNetShare [http://idekerlab.github.io/cy-net-share/]’s
Visual Style dropdown, and you can apply the style by selecting it in
the list. CyNetShare’s initial display uses the visual style named “default” –
use the Visual Style dropdown to choose the style in effect when Cytoscape
generated the .cyjs and .json files.

Note that the mechanics of generating a URL for a file in a public
directory system is a fast moving topic. Until recently, systems like
Dropbox (and others) allowed users to create a URL that resolved
directly to a file – a “direct” URL would be appropriate for use with
CyNetShare [http://idekerlab.github.io/cy-net-share/].
As of this writing, some public directory systems (e.g., Dropbox)
generate “shareable” URLs instead, which resolve to a web page that
allows file download – a “shareable” URL doesn’t work with
CyNetShare [http://idekerlab.github.io/cy-net-share/]. Systems that offer “shareable” URLs may offer “direct” URLs as
part of their premium (or Pro) package. To tell if your public directory
system generates a “direct” URL, have it generate a URL for a file, then
paste the URL into the address field of a browser and observe whether
the browser displays the file itself (good!) or a download page for the
file (bad!).

Hint: if Dropbox generates a “shareable” link that looks like
https://www.dropbox.com/s/w5e7towcchuvdeu/cynetworm.cyjs?dl=0,
you may be able to create a “direct” link by changing the dl=0 to dl=1: https://www.dropbox.com/s/w5e7towcchuvdeu/cynetworm.cyjs?dl=1.

A simple strategy for always getting a “direct” URL is to store your
file in a public directory served up by a web server, if you have access
to one – a URL served by a web server might appear as:
http://myserver.com/~mypublicdir/netstyle.json.

Alternately, you can use Gist [http://gist.github.com/] to create a
shareable document having a “direct” URL. To try this:


	Use Cytoscape to generate your network as a .cyjs file on your local
disk


	Use an editor to open the file and copy its contents to the
clipboard


	Use a web browser to surf to Gist [http://gist.github.com/]


	Paste the contents into a Gist document


	Select Create public Gist


	Select Raw to place the “direct” URL into your browser’s
address field


	Use that URL with
CyNetShare [http://idekerlab.github.io/cy-net-share/]




 




Generating a Full Web Application

The full page export option is designed for users who want to publish
their network as a complete single-page
application [http://en.wikipedia.org/wiki/Single-page_application].
Cytoscape creates a zip archive containing a complete
JavaScript [https://en.wikipedia.org/wiki/JavaScript]-based
web application that works as a basic viewer (like
CyNetShare [http://idekerlab.github.io/cy-net-share/])
for Cytoscape-generated network visualizations. You can unzip the
archive onto a web server (or your PC) and view the network via a web
browser on PCs and tablets.

[image: web_export_full.png]

To generate an entire web page for all networks in the session as a zip
archive, select File → Export as Web Page…. The following dialog
will appear:

[image: web_export_full_dialog.png]

This simple dialog has only two options - the file name and the type of
web export (full, simple network view, or JSON). For full web application,
we use the default. The file name is suggested based on the name of the
selected table with the path defaulting to the current working directory.
As in raw data export, the suggested file name can be changed using the
Browse button or the text field. Press OK to export a web archive with
the given file name.

To view the web page, unzip the archive into a folder on your PC or web
server. The folder will contain an index.html file, the network
data, and other files. You can open the index.html file in your
browser (usually from your browser’s File → Open menu item.)

Here is an example exported file from Cytoscape:


	Example full export deployed to web
server [http://chianti.ucsd.edu/~kono/webapp/cytoscape-export-full/]


	Archive file [http://cl.ly/XjMs/cytoscape_full_export.zip]




[image: web_export_full2.png]

Note that because Cytoscape uses the latest HTML5-based web
technologies, it cannot support older or non-conformant web browsers
such as Internet Explorer. We strongly recommend using the latest
version of modern web browsers such as Google Chrome, Mozilla Firefox,
or Apple Safari.

 




Generating a Simple Network View (For Web Application Developers)

The Simple Network View export option is designed for users who want to
publish their data as a complete single-page
application [http://en.wikipedia.org/wiki/Single-page_application], but
are interested in customizing the web viewer application themselves.
Cytoscape creates a zip archive containing a partial
JavaScript [https://en.wikipedia.org/wiki/JavaScript]-based
web application based on the cytoscape.js library and including simple
“boilerplate” code and the current network view. The user can create a
custom viewer by customizing this code.

[image: web_export_simple.png]

To generate a web page for a single network view as a zip archive, select
File → Export as Web Page … as before, but this time choose the
Simple viewer for current network only format as below:

[image: web_export_simple_dialog.png]

Everything else works as before, though this time the viewer will only
include the current network. Press OK to proceed with the export.

For instructions on testing the customized web application, see
Generating a Full Web Application above.

 




Extending the webpage with Cytoscape.JS functionality

As of version 3.6.2 of the JSON Support core app in Cytoscape, the user
may add custom Cytoscape.JS events [http://js.cytoscape.org/#core/events]
to the exported webpage.  In the web_session/scripts directory, a custom.js
file has been added with a designated spot for custom JS code.

For example, to add linkouts to nodes in the webpage (i.e. opening a
URL specified by the “href” node attribute when the user clicks the node),
the custom.js file should look like:

// Notice that the `cy` object may only be referenced 
// after the document has finished loading.

$( document ).ready(function(){  
  cy.on('tap', 'node', function(){
    try { // your browser may block popups
      window.open( this.data('href') );
    } catch(e){ // fall back on url change
      window.location.href = this.data('href');
    }
  });
});





This change has to be made each time you export a web
page. If you want to change the default export template, refer to the next section.

 




Customize Export Template (For Web Application Developers)

The code generated by Cytoscape for the Full Web Application and the
Simple Network View web applications is minimalistic. While you can
directly modify this code yourself to create your own page design or add
new features, the modifications will apply to a single exported network.
If you are a web application developer, you can change the application
code generated for all exports by editing HTML5 template code
resource files in your ~/CytoscapeConfiguration/web directory:

[image: web_folder.png]

In this folder, you can find full and simple sub directories
corresponding to Full Web Application and the Simple Network View
described above.


Requirements

To build these project, you need the following tools installed:


	Node.js


	gulp


	grunt







Full Export Template

This is an AngularJS based web application built with grunt (at least
for now – we have plans to migrate to gulp). Source code and more
documentations are available here:

* https://github.com/idekerlab/cyjs-full-export

To build the project into dist directory, type:

grunt








Simple Export Template

This template is generated by a simple gulp [http://gulpjs.com/]
project. The source code is available here:


	https://github.com/idekerlab/cyjs-export-simple




To build the project into dist directory, type:

gulp








Use Your Custom Templates for Export

Once you have your own builds, you can deploy your templates by
replacing the contents of full and simple with your own builds.
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23. Cytoscape and OpenCL (Computing on the GPU)

 


23.1. What it is for?

Cytoscape has basic support for offloading computationally intesive tasks
for parallel processing on a GPU, multicore CPU or a multiprocessor card
using OpenCL [https://en.wikipedia.org/wiki/OpenCL].
The OpenCL support in Cytoscape is mostly intended
to provide a unifying OpenCL access for third-party Cytoscape Apps,
but  some core functionality (Prefuse layout) also has OpenCL implementation
for increased performance.

As OpenCL can run on almost any device, including desktop computers
without dedicated GPUs,
you should be able to use OpenCL functionality on any platform
where you can run Cytoscape, although you may need to install
additional drivers for your device.

 




23.2. Setup & Configuration

The CyCL core app (should be already part of your Cytoscape distribution)
lets you see the available OpenCL devices and configure your preferred device for OpenCL computation.
To see the device list and configure your preferred device,
select Edit → Preferences → OpenCL Settings…

[image: OpenCL configuration dialog]

In most cases, you want your preferred device to be your GPU (if you have one).
If you do not see the device you intend to use (or any device at all)
in the configuration window,
you may need to install OpenCL drivers.
For GPUs from major manufacturers, OpenCL drivers are usually installed
with the graphics driver. If you have installed the latest graphics drivers and still do not see your device in the list, check the website of your GPU manfucturer.
To use OpenCL on a CPU (i.e., on any desktop computer) or a Xeon Phi,
you need to install the drivers separately from
the web page of the manufacturer of your CPU.

As of 2017-01-06, drivers for Intel CPUs can be downloaded at
https://software.intel.com/en-us/articles/opencl-drivers#latest_CPU_runtime -
look for “runtime-only”. AMD’s drivers can be found at http://support.amd.com/en-us/kb-articles/Pages/OpenCL2-Driver.aspx.

Warning: After you have just installed drivers for your OpenCL device,
Cytoscape may require restarting to be able to “see” the device.

 




23.3. OpenCL/GPU Troubleshooting

If any OpenCL app is not working, here are some of the common causes:


CyCL core app is not installed or not initialized property

Diagnosis: check if you can see the Edit → Preferences → OpenCL Settings… menu item.
If not, this is a bad sign.

Treatment: Check the CytoscapeConfiguration directory,
if it contains a file called disable-opencl.dummy remove it and start Cytoscape
from the system console (using cytoscape.bat or cytoscape.sh).
Check console output for additional information.




No OpenCL devices are available

Diagnosis and treament: See Setup and configuartion above.




The Cytoscape console says “Could not find OpenCL.dll”

Treatment: Make sure your Windows OS directory containing OpenCL.dll is listed in the
value of the Java system property java.library.path
(OpenCL.dll can usually be found in %windir\SysWOW64% or %windir%\system32).
You can modify java.library.path by adding a line of the form
-Djava.library.path=path1;path2 to the Cytoscape.vmoptions file.
Cytoscape.vmoptions can be found in the Cytoscape installation directory.




The computer is unresponsive for a while and then resets the screen while running OpenCL on the GPU.

Treatment: This problem arises
if you run computations on the GPU that also handles your main display and
the computation occupies the GPU for too long,
preventing the operating system (e.g., Windows) from updating the display.
If the operating system detects this, it terminates the GPU computation.
You can either try to run smaller chunks of the computation or configure
the “Timeout Detection and Recovery” (TDR) to let the computation complete
even if the system becomes unresponsive.
Further info can be found at this NVidia thread [https://devtalk.nvidia.com/default/topic/459869/-quot-display-driver-stopped-responding-and-has-recovered-quot-wddm-timeout-detection-and-recovery-/]
or Microsoft webpage [https://msdn.microsoft.com/en-us/library/windows/hardware/ff570087(v=vs.85).aspx].
Microsoft also has documentation for the registry keys that need to changed [https://msdn.microsoft.com/en-us/library/windows/hardware/ff569918(v=vs.85).aspx].




My problem is not listed here

Try to install drivers for your CPU and run on the CPU platform (see links above). CPU platforms offer lower performance, but are generally more reliable.
If this does not help you, ask for help in the
Cytoscape helpdesk mailing list [https://groups.google.com/forum/#!forum/cytoscape-helpdesk].
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24. Cytoscape.js and Cytoscape

 


24.1. What is Cytoscape.js?

[image: jsWebSite.png]

Cytoscape.js [http://cytoscape.github.io/cytoscape.js/] is a
JavaScript library for interactive network visualization. It is a
building block for web applications and is NOT a complete web
application. If you have network data sets and want to share
visualizations created with Cytoscape, you can build your own website
using Cytoscape.js and this new Export to Cytoscape.js feature.

 


Examples


	A network visualized with Cytoscape 3.1.0

[image: sampleOriginal.png]



	Same network exported to Cytoscape.js (Rendered with Google Chrome
and Cytoscape.js 2.0.3)

[image: sampleExport.png]



	Interactive example (galFiltered.sif rendered with
Cytoscape.js 2.0.3) [http://chianti.ucsd.edu/~kono/dist/]




 




Differences and Shared Concepts

Although Cytoscape and Cytoscape.js are two completely independent
software packages, they are sharing higher level concepts. The following
is the list of similarities and differences between the two:


Cytoscape


	Desktop application for network visualization written in Java
programming language [http://www.java.com/]


	Needs desktop or laptop computers to run


	Users have to install Java runtime


	High performance application for large scale network analysis and
visualization


	Expandable by Apps [http://apps.cytoscape.org/]


	Use Styles to map data to network properties, such as node
color, edge width, node shape, etc.







Cytoscape.js


	A JavaScript library [http://en.wikipedia.org/wiki/JavaScript]
for network visualization, NOT a complete web application nor
mobile app


	Runs on most of modern web browsers, including tablets and smart
phones


	No plugins are required to run. Modern web browser is the only
requirement


	Need to write code to set up your web site or web application


	Expandable by
Extensions [http://cytoscape.github.io/cytoscape.js/#extensions]


	Use CSS-based Styles to map data to network properties




In a long term, Cytoscape and Cytoscape.js will be more integrated, and
as the first step Cytoscape now supports reading and writing
Cytoscape.js network/table JSON files. In addition, Cytoscape can
convert Styles to Cytoscape.js Style object.

 








24.2. Data Exchange between Cytoscape and Cytoscape.js

Since Cytoscape.js is a JavaScript library, its basic data exchange
format is JSON (JavaScript Object Notation) [http://www.json.org/]. All
of these import/export functions are part of standard Cytoscape user
interface, and you can read/write Cytoscape.js JSON files just like
other standard files such as SIF.

 


Export Network and Table to Cytoscape.js

Cytoscape.js stores network data (graph) and its data table in the same
object. Cytoscape writes such data complex as JSON, i.e., both network
and data tables will be exported as a single JSON file. You can select a
network and export it from File | Export | Network.

Cytoscape only supports one of the Cytoscape.js supported JSON formats,
which is:

{
    elements:{
        nodes:[],
        edges:[]
    }
}





SUID will be used as unique identifier for nodes and edges in the
JSON. For more information about this format, please visit Cytoscape.js
web site [http://cytoscape.github.io/cytoscape.js/].


Important Note about Data Compatibility

Cytoscape creates JSON file directly from data table and tries to
extract as much data as possible from the original table. However, since
table column names will be directly converted into
JavaScript [https://en.wikipedia.org/wiki/JavaScript]
variable names, invalid characters will be replaced by underscore (_):


	Original Data Table Column Names:

Gene Name
KEGG.pathway







	The Names above will be replaced to:

Gene_Name
KEGG_pathway









You should be careful when you plan to use this feature for data
roundtrip: from Cytoscape to Cytoscape.js back to Cytoscape. For such
use cases, we strongly recommend to use
JavaScript [https://en.wikipedia.org/wiki/JavaScript]-safe
characters only in your table column names. Naming your columns only
with alphanumeric characters and underscore (_) is the best practice.
(For actual data entries, all characters are allowed. This restriction
is only for table column names.)

 








24.3. Export Styles to Cytoscape.js

Cytoscape and Cytoscape.js are sharing a concept called Style. This
is a collection of mappings from data point to network property.
oCytoscape can export its Styles into CSS-based Cytoscape.js JSON.

You can export all Styles into one JSON file from File | Export |
Styles and select Cytoscape.js JSON as its format.


Limitations

Cytoscape.js does not support all of Cytoscape Network Properties. Those
properties will be ignored or simplified when you export to JSON Style
file.

Currently, the following Visual Properties will not be exported to
Cytoscape.js JSON:


	Custom Graphics and its positions


	Edge Bends


	Tooltips


	Node Label Width


	Node Border Line Type


	Arrow Colors (they are always same as edge color)







Cytoscape.js and Cytoscape Compatibility

Cytoscape’s network rendering system is designed for desktop use, while the browser-based renderer
incorporates web technologies (e.g., cytoscape.js and Cascaded Style Sheets). As a result, most but
not all networks will render the same in the browser as in Cytoscape. Cytoscape visual styles not
supported in the web browser are ignored. A complete compatibility list is available
here [https://docs.google.com/spreadsheets/d/1iTDKGjro1-L7HGz1ftozqDKRxjQVSPF28jQLt7XGrSg/edit#gid=0].

 




Import Cytoscape.js data into Cytoscape

Cytoscape.js network JSON files can be loaded from standard Cytoscape
file menu: File | Import | Network …. Both File and URL are
supported.

 






24.4. Build Your Own Web Application with Cytoscape.js

Although Cytoscape can export networks, tables, and Style as
Cytoscape.js-compatible JSON, users have to write some
JavaScript [https://en.wikipedia.org/wiki/JavaScript]
code to visualize the data files with Cytoscape.js. Details of web
application development with Cytoscape.js is beyond the scope of this
document. If you need examples and tutorials about web application
development with Cytoscape.js, please visit the following web site:


	https://github.com/cytoscape/cyjs-sample/wiki




 


Questions?

If you have questions and comments about web application development
with Cytoscape and Cytoscape.js, please send yours to our mailing
list [https://groups.google.com/forum/#!forum/cytoscape-discuss].
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25. Cytoscape Automation

Cytoscape Automation is a collection of features that enable users to create workflows executed entirely within Cytoscape or by external tools (e.g., RStudio [https://www.rstudio.com/], Jupyter [https://jupyter.org/], GenomeSpace [http://www.genomespace.org/], etc), and whose results are reproducible. This enables Cytoscape to scale to large collections of datasets and to larger more complex workflows than is practical via keyboard and mouse.

Cytoscape Automation exists in two skins – the Commands interface and the Functions interface. Both can accomplish similar results, but are focused on different usage styles. Commands reprise user-initiated interactions (e.g., open session, import data, export image), whereas Functions enable programmers to manipulate and operate on networks as internal Cytoscape data. Commands and Functions both call Cytoscape (and Cytoscape apps) via a REST interface known as CyREST.

This chapter describes how to produce custom workflows using CyREST natively and via Python and R interface libraries. More tutorials and examples are available at the Cytoscape Automation web page (https://github.com/cytoscape/cytoscape-automation/wiki).

Note that for a Cytoscape app to be callable via CyREST, the app must be installed into Cytoscape and the author must have
specifically added automation functionality to it. If there is
an app you would like to call, but which doesn’t offer automation, please contact the app author and request that app functionality be
added. Instructions for adding automation to an app are available on the Cytoscape Automation web page (https://github.com/cytoscape/cytoscape-automation/wiki).

 


25.1. Background

Cytoscape’s intuitive graphical user interface is useful for
interactive network data integration, analysis, and visualization. It
provides great features for exploratory data analysis, but what happens
if you have hundreds of data files or need to ask someone to execute
your data analysis workflows? It is virtually impossible to apply the
same operations to hundreds of networks manually using a GUI. More
importantly, although you can save your results as session files,
you cannot save your workflows if you perform your data analysis
with point-and-click GUI operations. Cytoscape has several options that
support automating your workflows, all under the umbrella of Cytoscape Automation:

[image: CytoscapeAutomation_3.png]

The Commands feature allows you to script a sequence of Cytoscape commands
and menu items, where commands can have parameter values that would
normally be provided by a user via a Cytoscape dialog box. For example,
session open file=”C:\myfile.cys” loads a session from a file
similarly to the File | Open menu item. Commands may
resolve to Cytoscape core functions or automation-enabled apps installed in
Cytoscape. You can create a command
script file that Cytoscape can execute via the Tools | Execute Command
File menu item or on the Cytoscape command line at startup.

The CyREST API feature allows you to access Cytoscape from a separate
application, thereby orchestrating Cytoscape operations via HTTP-based REST calls.
Your workflows can execute either Commands or Functions in this way.

Automation applications may be written in a general programming
language that keeps its own data structures, performs
complex flow control, or directly manipulates Cytoscape nodes, edges,
attributes, and visual styles. For R and Python, we provide language-specific
interface libraries (e.g., r2cytoscape and py2cytoscape) that present
Cytoscape Automation in language-friendly terms, and call Cytoscape and apps via
the CyREST interface.

 




25.2. Commands

[image: AutomationPanel.png]

Commands is the built-in Cytoscape feature to automate your
workflow as simple script. You can learn more about Commands in the Command Tool
section.

 




25.3. CyREST Interface Layer

In some cases, you may need to leverage the complex control and data structures available in a fully featured programming language,
such as R [http://www.r-project.org/], Python [https://www.python.org/], Ruby [https://www.ruby-lang.org/en/] or
JavaScript [https://en.wikipedia.org/wiki/JavaScript]. Such languages enable complex Cytoscape-centric workflows or the integration of Cytoscape into larger workflows. Cytsocape enables progamatic access to both its Commands and Functions via its CyREST interface.

By default, the CyREST interface is enabled and available on TCP/IP port 1234. To verify this, start a web browser on
your Cytoscape workstation and surf to either http://localhost:1234/v1/ or http://localhost:1234/v1/commands. The first form is a Function that returns basic Cytoscape information as a JSON object:

[image: FunctionAPI.png]

The second form is a Command that returns a list of available Command namespaces:

[image: CommandAPI.png]

Note that the list of namespaces will vary depending on the apps you install – some apps provide Commands in namespaces of their own.

If your workstation has port 1234 already in use, you can specify a different CyREST port in two ways:


	Use the Edit → Preferences menu to alter the rest.port property to select a different port (e.g., 8888)


	Specify the port on the Cytoscape command line via the -R parameter:




     cytoscape.bat -R 8888 (for Windows)
     
     ./cytoscape.sh -R 8888 (for Mac or Linux)





You can test the new port by using your browser to surf to http://localhost:8888/v1/

Note that if you expect to run more than one instance of Cytsocape on a single workstation, the CyREST port must be unique for each Cytoscape instance. You must use either the property or command line parameter technique to execute each instance with a different CyREST port.

 


Exploring CyREST Commands and Functions

Cytoscape makes a list of available Commands and Functions available via the Help → Automation submenus. The CyREST API submenu shows available Functions, and CyREST Command API shows available Commands. Automation Examples leads to a web portal containing the bulk of documentation, samples and tutorials for Cytsocape Automation in general.

[image: automation_menu.png]

Notably, Automation Examples contains a tutorial that explains how to explore CyREST Commands and Functions: https://github.com/cytoscape/cytoscape-automation/wiki/Trying-Automation.

The CyREST API and CyREST Command API submenus document CyREST in a Swagger web application, which allows you to explore CyREST entrypoints by reading about them and invoking them directly (using a Try it out!) button. A sample page matching the http://localhost:1234/v1/ Function is:

[image: swagger_v1.png]

Note that the page contains a description, input parameters, output values, result code and the Try it out! button. Pressing the button executes the Function and shows the actual CyREST call and its results. Making good use of Swagger as a prototyping tool can greatly reduce code writing and debug time!

[image: swagger_v1_result.png]

To find out more about how to use CyREST, visit the Cytoscape Automation tutorial pages (https://github.com/cytoscape/cytoscape-automation/wiki/Trying-Automation).

Note that Swagger pages reflect functionality in Cytoscape at the time it executes, including Commands and Functions contributed by installed apps. To discover CyREST functionality in uninstalled apps, you must first install them, and then use Help → Automation submenus to generate the Swagger pages (or simply reload your Swagger browser page).

 






25.4. cyREST and R/Python

CyREST enables access to Cytoscape Automation features from workflows written in high level languages (e.g., R [http://www.r-project.org/] and Python [https://www.python.org/]) and executing in separate environments (e.g., RStudio [https://www.rstudio.com/] and Jupyter [https://jupyter.org/]) on the Cytoscape workstation. A workflow can call Commands and Functions either directly via CyREST or via language-specific interface libraries.

To directly call CyREST Commands and Functions from a workflow, see the mini-tutorial.

To understand and get started using language-specific libraries, visit the Cytoscape Automation web page (https://github.com/cytoscape/cytoscape-automation/wiki). The Workflow Index page [https://github.com/cytoscape/cytoscape-automation/wiki/Workflow-Index] contains useful code samples, and the Sample Scripts page [https://github.com/cytoscape/cytoscape-automation/tree/master/for-scripters] contains working demonstration projects.

Below is a sample Jupyter-based Python script and the resulting sample output.

[image: jupyter.png]

(Sample Jupyter
Notebook [http://nbviewer.ipython.org/github/idekerlab/py2cytoscape/blob/develop/examples/New_wrapper_api_sample.ipynb]
written with cyREST and
py2cytoscape [https://github.com/idekerlab/py2cytoscape])
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26. Cytoscape Privacy Policy

We respect the privacy of all Cytoscape users, and we do not collect any
information on Cytoscape users except in the situations listed below. In
no case do we attempt to tie any of this information back to a user, nor
do we give, share, sell, or transfer this information to any third party
unless required by law. We use this information only in the aggregate to
generate statistics to assist in securing continued funding for
Cytoscape.


	On the Cytoscape download web page, we log the date, time, browser
signature, and IP address to which we deliver Cytoscape.


	When Cytoscape starts, it fetches news and version information
from a Cytoscape server. We log the date, time, and IP address
of the workstation running Cytoscape.


	During Cytoscape execution, we log usage statistics tagged with the date,
time, and IP address of the workstation running Cytoscape. This
logging can be turned off during Cytoscape installation or by
setting the installoptions.shareStatistics property to false using
the Cytoscape Preferences Editor.




This policy may change from time to time, and if it does, we will notify
you via our normal mass notification media. We will also update this
section of the user manual.

Note that some internal Cytoscape Apps and Apps available through the
Cytoscape App Store connect with third party services via the Internet.
Once an App links to such a service, you are subject to the privacy
policy of that service.
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27. Basic Expression Analysis Tutorial

The Cytoscape Basic Data Visualization tutorial is now available here [https://cytoscape.org/cytoscape-tutorials/protocols/basic-data-visualization/#/].

The complete set of Cytoscape tutorials is available at tutorials.cytoscape.org [http://tutorials.cytoscape.org/].
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Ontology and Annotation Import

Annotations in Cytoscape are stored as a set of ontologies (e.g. the
Gene Ontology, or GO). An ontology consists of a set of controlled
vocabulary terms that annotate the objects. For example, using the Gene
Ontology, the Saccharomyces Cerevisiae CDC55 gene has a biological
process described as “protein biosynthesis”, to which GO has assigned
the number 6412 (a GO ID).

GO 8150 biological_process


	GO 7582 physiological processes


	GO 8152 metabolism


	GO 44238 primary metabolism


	GO 19538 protein metabolism


	GO 6412 protein biosynthesis




















Graphical View of GO Term 6412: protein biosynthesis

[image: ontology_dag1.png]

Cytoscape can use this ontology DAG (Directed Acyclic Graph) to annotate
objects in networks. The Ontology Server (originally called
“BioDataServer (http://www.ncbi.nlm.nih.gov/pubmed/12066840)”)
is a Cytoscape feature which allows you to load, navigate, and assign
annotation terms to nodes and edges in a network. Cytoscape 2.4 now has
an enhanced GUI for loading ontology and associated annotation, enabling
you to load both local and remote files.

 


Ontology and Annotation File Format

The standard file formats used in the Cytoscape Ontology Server are
OBO and Gene Association. The GO website details these file formats:

Ontologies and Definitions:
http://www.geneontology.org/GO.downloads.shtml#ont

Current Annotations:
http://www.geneontology.org/GO.current.annotations.shtml

 




Default List of Ontologies

Cytoscape provides a list of ontologies available in OBO format. If an
Internet connection is available, Cytoscape will import ontology and
annotation files directly from the remote source. The table below lists
the included ontologies.


Default List of Ontologies
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